diff mbox series

[bug#60120,08/28] gnu: Add ocaml-optint.

Message ID 20221216132527.2539-8-pukkamustard@posteo.net
State New
Headers show
Series gnu: Add ocaml-5.0. | expand

Commit Message

pukkamustard Dec. 16, 2022, 1:25 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-optint): New variable.
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 58eef28558..7118f88318 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2742,6 +2742,31 @@  (define-public ocaml-psq
 Typical applications are searches, schedulers and caches.")
     (license license:isc)))
 
+(define-public ocaml-optint
+  (package
+    (name "ocaml-optint")
+    (version "0.2.0")
+    (home-page "https://github.com/mirage/optint")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url home-page)
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256 (base32
+                 "0d82nf9w46zbyfq3h3n2b9jajvv8gndjyc168xzzk328vj63i12p"))))
+    (build-system dune-build-system)
+    (arguments `(#:test-target "."))
+    (native-inputs (list ocaml-crowbar ocaml-monolith ocaml-fmt))
+    (synopsis "Efficient integer types on 64-bit architectures for OCaml")
+    (description
+     "This OCaml library provides two new integer types, @code{Optint.t} and
+@code{Int63.t}, which guarantee efficient representation on 64-bit
+architectures and provide a best-effort boxed representation on 32-bit
+architectures.")
+    (license license:isc)))
+
 (define-public ocaml-lwt
   (package
     (name "ocaml-lwt")