mbox series

[bug#49867,00/29] gnu: Add ocaml-cohttp-lwt-unix.

Message ID 20210804071015.20848-1-pukkamustard@posteo.net
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Message

pukkamustard Aug. 4, 2021, 7:10 a.m. UTC
Hi,

These patches add ocaml-cohttp-lwt-unix - an OCaml HTTP library - and dependencies.

Some known rough edges:

- ocaml-eqaf: Tests are disabled for now as I am not able to build ocaml-afl-persistent which is a dependency for ocaml-crowbar which is required to run ocaml-eqaf tests. There is ongoing work to port ocaml-afl-persistent to dune (https://github.com/stedolan/ocaml-afl-persistent/pull/7) with that it should be much easier to build it and enable tests for ocaml-eqaf.
- ocaml-mirage-crypto-ec: Contains generated code from Fiat-Crypto (https://github.com/mit-plv/fiat-crypto). It would be nicer to generate the C code from the Coq sources during Guix build, but that seems like a lot more work.
- ocaml-ca-certs: Tests requie access to `/etc/ssl/certs/*` which does not seem to be available during tests. Any ways to allow this in the test environment?
- ocaml-cohttp-lwt-unix: Seems to require network during tests. Can someone confirm this?

Thanks,
pukkamustard


pukkamustard (29):
  gnu: Add ocaml-cohttp-lwt.
  gnu: Add ocaml-domain-name.
  gnu: Add ocaml-macaddr.
  gnu: Add ocaml-ipaddr.
  gnu: Add ocaml-ipaddr-cstruct.
  gnu: Add ocaml-ipaddr-sexp.
  gnu: Add ocaml-conduit.
  gnu: Add ocaml-conduit-lwt.
  gnu: Add ocaml-eqaf.
  gnu: Add ocaml-mirage-crypto.
  gnu: Add ocaml-duration.
  gnu: Add ocaml-randomconv.
  gnu: Add ocaml-mirage-crypto-rng.
  gnu: Add ocaml-mirage-crypto-pk.
  gnu: Add ocaml-ptime.
  gnu: Add ocaml-asn1-combinators.
  gnu: Add ocaml-ppx-deriving.
  gnu: Add ocaml-ppx-deriving-yojson.
  gnu: Add ocaml-mirage-crypto-ec.
  gnu: Add ocaml-gmap.
  gnu: Add ocaml-pbkdf.
  gnu: Add ocaml-cstruct-unix.
  gnu: Add ocaml-x509.
  gnu: Add ocaml-ca-certs.
  gnu: Add ocaml-lwt-log.
  gnu: Add ocaml-lwt-ssl.
  gnu: Add ocaml-conduit-lwt-unix.
  gnu: Add ocaml-magic-mime.
  gnu: Add ocaml-cohttp-lwt-unix

 gnu/packages/ocaml.scm | 787 ++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 786 insertions(+), 1 deletion(-)

Comments

pukkamustard Nov. 15, 2021, 1:23 p.m. UTC | #1
Closing this issue for the moment as I'm no longer using
ocaml-cohttp-lwt-unix, it is a considerable series and effort is
probably better spent elsewhere.

Feel free to reopen or recycle if interested in the packages.

pukkamustard <pukkamustard@posteo.net> writes:

> Hi,
>
> These patches add ocaml-cohttp-lwt-unix - an OCaml HTTP library - and dependencies.
>
> Some known rough edges:
>
> - ocaml-eqaf: Tests are disabled for now as I am not able to build ocaml-afl-persistent which is a dependency for ocaml-crowbar which is required to run ocaml-eqaf tests. There is ongoing work to port ocaml-afl-persistent to dune (https://github.com/stedolan/ocaml-afl-persistent/pull/7) with that it should be much easier to build it and enable tests for ocaml-eqaf.
> - ocaml-mirage-crypto-ec: Contains generated code from Fiat-Crypto (https://github.com/mit-plv/fiat-crypto). It would be nicer to generate the C code from the Coq sources during Guix build, but that seems like a lot more work.
> - ocaml-ca-certs: Tests requie access to `/etc/ssl/certs/*` which does not seem to be available during tests. Any ways to allow this in the test environment?
> - ocaml-cohttp-lwt-unix: Seems to require network during tests. Can someone confirm this?
>
> Thanks,
> pukkamustard
>
>
> pukkamustard (29):
>   gnu: Add ocaml-cohttp-lwt.
>   gnu: Add ocaml-domain-name.
>   gnu: Add ocaml-macaddr.
>   gnu: Add ocaml-ipaddr.
>   gnu: Add ocaml-ipaddr-cstruct.
>   gnu: Add ocaml-ipaddr-sexp.
>   gnu: Add ocaml-conduit.
>   gnu: Add ocaml-conduit-lwt.
>   gnu: Add ocaml-eqaf.
>   gnu: Add ocaml-mirage-crypto.
>   gnu: Add ocaml-duration.
>   gnu: Add ocaml-randomconv.
>   gnu: Add ocaml-mirage-crypto-rng.
>   gnu: Add ocaml-mirage-crypto-pk.
>   gnu: Add ocaml-ptime.
>   gnu: Add ocaml-asn1-combinators.
>   gnu: Add ocaml-ppx-deriving.
>   gnu: Add ocaml-ppx-deriving-yojson.
>   gnu: Add ocaml-mirage-crypto-ec.
>   gnu: Add ocaml-gmap.
>   gnu: Add ocaml-pbkdf.
>   gnu: Add ocaml-cstruct-unix.
>   gnu: Add ocaml-x509.
>   gnu: Add ocaml-ca-certs.
>   gnu: Add ocaml-lwt-log.
>   gnu: Add ocaml-lwt-ssl.
>   gnu: Add ocaml-conduit-lwt-unix.
>   gnu: Add ocaml-magic-mime.
>   gnu: Add ocaml-cohttp-lwt-unix
>
>  gnu/packages/ocaml.scm | 787 ++++++++++++++++++++++++++++++++++++++++-
>  1 file changed, 786 insertions(+), 1 deletion(-)