diff mbox series

[bug#49867,21/29] gnu: Add ocaml-pbkdf.

Message ID 20210804071545.21181-21-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-pbkdf): New variable.
---
 gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 3:55 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-pbkdf): New variable.
> ---
>  gnu/packages/ocaml.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index e520151adf..6effe1ff12 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7684,6 +7684,32 @@ Algebraic Data Type")
>  to create a type-safe heterogenous maps.")
>      (license license:isc)))
>  
> +(define-public ocaml-pbkdf
> +  (package
> +    (name "ocaml-pbkdf")
> +    (version "1.1.0")
> +    (home-page "https://github.com/abeaumont/ocaml-pbkdf")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0scq1i7hiy8dgjdfrcaca3k7wzys35k1g2cdg7v4kfdqr6q1scb3"))))
> +    (build-system dune-build-system)
> +    (propagated-inputs
> +     `(("ocaml-mirage-crypto" ,ocaml-mirage-crypto)))
> +    (native-inputs
> +     `(("ocaml-alcotest" ,ocaml-alcotest)))
> +    (synopsis "OCaml library for password based key derivation functions
> +(PBKDF) from PKCS#5")
> +    (description "An OCaml implementation of PBKDF 1 and 2 as defined by
> +PKCS#5 using @code{ocaml-mirage-crypto}.")

The description should contain full sentences, maybe

  "This package provides an OCaml implementation of …"
pukkamustard Aug. 8, 2021, 11:21 a.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

>> +    (description "An OCaml implementation of PBKDF 1 and 2 as 
>> defined by
>> +PKCS#5 using @code{ocaml-mirage-crypto}.")
>
> The description should contain full sentences, maybe
>
>   "This package provides an OCaml implementation of …"

Changed to: "This package provides an OCaml implementation of 
PBKDF 1 and 2 as defined by PKCS#5 using 
@code{ocaml-mirage-crypto}."

Note: A version 1.2.0 was released recently. However, it requires 
CStruct 6.0.0. I will submit a patch to update ocaml-cstruct and 
then ocaml-pbkdf can be updated to 1.2.0.
Xinglu Chen Aug. 9, 2021, 9:53 a.m. UTC | #3
On Sun, Aug 08 2021, pukkamustard wrote:

> Xinglu Chen <public@yoctocell.xyz> writes:
>
>>> +    (description "An OCaml implementation of PBKDF 1 and 2 as 
>>> defined by
>>> +PKCS#5 using @code{ocaml-mirage-crypto}.")
>>
>> The description should contain full sentences, maybe
>>
>>   "This package provides an OCaml implementation of …"
>
> Changed to: "This package provides an OCaml implementation of 
> PBKDF 1 and 2 as defined by PKCS#5 using 
> @code{ocaml-mirage-crypto}."
>
> Note: A version 1.2.0 was released recently. However, it requires 
> CStruct 6.0.0. I will submit a patch to update ocaml-cstruct and 
> then ocaml-pbkdf can be updated to 1.2.0.

Cool, sounds good.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e520151adf..6effe1ff12 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7684,6 +7684,32 @@  Algebraic Data Type")
 to create a type-safe heterogenous maps.")
     (license license:isc)))
 
+(define-public ocaml-pbkdf
+  (package
+    (name "ocaml-pbkdf")
+    (version "1.1.0")
+    (home-page "https://github.com/abeaumont/ocaml-pbkdf")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0scq1i7hiy8dgjdfrcaca3k7wzys35k1g2cdg7v4kfdqr6q1scb3"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+     `(("ocaml-mirage-crypto" ,ocaml-mirage-crypto)))
+    (native-inputs
+     `(("ocaml-alcotest" ,ocaml-alcotest)))
+    (synopsis "OCaml library for password based key derivation functions
+(PBKDF) from PKCS#5")
+    (description "An OCaml implementation of PBKDF 1 and 2 as defined by
+PKCS#5 using @code{ocaml-mirage-crypto}.")
+    (license license:bsd-2)))
+
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")