diff mbox series

[bug#49867,25/29] gnu: Add ocaml-lwt-log.

Message ID 20210804071545.21181-25-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-lwt-log): New variable.
---
 gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 4:18 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-lwt-log): New variable.
> ---
>  gnu/packages/ocaml.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index e832adc069..d475b75287 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7404,6 +7404,30 @@ establishing TCP and SSL/TLS connections from @code{ocaml-conduit} using
>  @code{ocaml-lwt}.")
>      (license license:isc)))
>  
> +(define-public ocaml-lwt-log
> +  (package
> +    (name "ocaml-lwt-log")
> +    (version "1.1.1")
> +    (home-page "https://github.com/ocsigen/lwt_log")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "1n12i1rmn9cjn6p8yr6qn5dwbrwvym7ckr7bla04a1xnq8qlcyj7"))))
> +    (build-system dune-build-system)
> +    (arguments `(#:test-target "."))
> +    (propagated-inputs `(("ocaml-lwt" ,ocaml-lwt)))
> +    (properties `((upstream-name . "lwt_log")))
> +    (synopsis "OCaml/Lwt logging library (deprecated)")
> +    (description "This OCaml library provides helpers for logging is
> +deprecated for @code{ocaml-logs}.")

This sentence is a bit weird, maybe

  This OCaml library provides helpers for logging; it has been
  deprecated in favor of @code{ocaml-logs}.

> +    (license license:lgpl2.1)))

COPYING[1] say lgpgl2.1+, and “with the additional exemption that
compiling, linking, and/or using OpenSSL is allowed”.  You can probably
put a comment that mentions the exemption.

[1]: <https://github.com/ocsigen/lwt_log/blob/master/COPYING>
pukkamustard Aug. 8, 2021, 1:01 p.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

> This sentence is a bit weird, maybe
>
>   This OCaml library provides helpers for logging; it has been
>   deprecated in favor of @code{ocaml-logs}.
>
>> +    (license license:lgpl2.1)))
>
> COPYING[1] say lgpgl2.1+, and “with the additional exemption 
> that
> compiling, linking, and/or using OpenSSL is allowed”.  You can 
> probably
> put a comment that mentions the exemption.
>
> [1]: <https://github.com/ocsigen/lwt_log/blob/master/COPYING>

While fixing the package definition, I notice that ocaml-lwt-log 
already existed. V2 removes my patch for adding ocaml-lwt-log.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e832adc069..d475b75287 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7404,6 +7404,30 @@  establishing TCP and SSL/TLS connections from @code{ocaml-conduit} using
 @code{ocaml-lwt}.")
     (license license:isc)))
 
+(define-public ocaml-lwt-log
+  (package
+    (name "ocaml-lwt-log")
+    (version "1.1.1")
+    (home-page "https://github.com/ocsigen/lwt_log")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1n12i1rmn9cjn6p8yr6qn5dwbrwvym7ckr7bla04a1xnq8qlcyj7"))))
+    (build-system dune-build-system)
+    (arguments `(#:test-target "."))
+    (propagated-inputs `(("ocaml-lwt" ,ocaml-lwt)))
+    (properties `((upstream-name . "lwt_log")))
+    (synopsis "OCaml/Lwt logging library (deprecated)")
+    (description "This OCaml library provides helpers for logging is
+deprecated for @code{ocaml-logs}.")
+    (license license:lgpl2.1)))
+
 (define-public ocaml-eqaf
   (package
     (name "ocaml-eqaf")