diff mbox series

[bug#49867,27/29] gnu: Add ocaml-conduit-lwt-unix.

Message ID 20210804071545.21181-27-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-conduit-lwt-unix): New variable.
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 4:20 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-conduit-lwt-unix): New variable.
> ---
>  gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index cadd22cb9c..8904f2df19 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7454,6 +7454,31 @@ deprecated for @code{ocaml-logs}.")
>  performs I/O concurrently.")
>  (license license:lgpl2.1+))) ; with linking exception
>  
> +(define-public ocaml-conduit-lwt-unix
> +  (package
> +    (inherit ocaml-conduit)
> +    (name "ocaml-conduit-lwt-unix")
> +    (arguments `(#:package "conduit-lwt-unix"
> +                 #:test-target "."))
> +    (propagated-inputs
> +     `(("ocaml-logs" ,ocaml-logs)
> +       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
> +       ("ocaml-conduit-lwt" ,ocaml-conduit-lwt)
> +       ("ocaml-lwt" ,ocaml-lwt)
> +       ("ocaml-uri" ,ocaml-uri)
> +       ("ocaml-ipaddr" ,ocaml-ipaddr)
> +       ("ocaml-ipaddr-sexp" ,ocaml-ipaddr-sexp)
> +       ("ocaml-ca-certs" ,ocaml-ca-certs)))
> +    (native-inputs
> +     `(("ocaml-lwt-log" ,ocaml-lwt-log)
> +       ("ocaml-ssl" ,ocaml-ssl)
> +       ("ocaml-lwt-ssl" ,ocaml-lwt-ssl)))
> +    (synopsis "OCaml library for establishing TCP and SSL/TLC connections using Lwt_unix")

Keep lines at ~80 characters.  :-)
pukkamustard Aug. 8, 2021, 1:06 p.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

>> +    (synopsis "OCaml library for establishing TCP and SSL/TLC 
>> connections using Lwt_unix")
>
> Keep lines at ~80 characters.  :-)

Thanks! Fixed in V2.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cadd22cb9c..8904f2df19 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7454,6 +7454,31 @@  deprecated for @code{ocaml-logs}.")
 performs I/O concurrently.")
 (license license:lgpl2.1+))) ; with linking exception
 
+(define-public ocaml-conduit-lwt-unix
+  (package
+    (inherit ocaml-conduit)
+    (name "ocaml-conduit-lwt-unix")
+    (arguments `(#:package "conduit-lwt-unix"
+                 #:test-target "."))
+    (propagated-inputs
+     `(("ocaml-logs" ,ocaml-logs)
+       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+       ("ocaml-conduit-lwt" ,ocaml-conduit-lwt)
+       ("ocaml-lwt" ,ocaml-lwt)
+       ("ocaml-uri" ,ocaml-uri)
+       ("ocaml-ipaddr" ,ocaml-ipaddr)
+       ("ocaml-ipaddr-sexp" ,ocaml-ipaddr-sexp)
+       ("ocaml-ca-certs" ,ocaml-ca-certs)))
+    (native-inputs
+     `(("ocaml-lwt-log" ,ocaml-lwt-log)
+       ("ocaml-ssl" ,ocaml-ssl)
+       ("ocaml-lwt-ssl" ,ocaml-lwt-ssl)))
+    (synopsis "OCaml library for establishing TCP and SSL/TLC connections using Lwt_unix")
+    (description "This OCaml library provides an implementation for
+establishing TCP and SSL/TLS connections for the @code{ocaml-conduit}
+signatures using Lwt_unix.")
+    (license license:isc)))
+
 (define-public ocaml-eqaf
   (package
     (name "ocaml-eqaf")