diff mbox series

[bug#49867,29/29] gnu: Add ocaml-cohttp-lwt-unix

Message ID 20210804071545.21181-29-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-cohttp-lwt-unix): New variable.
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 4:25 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-cohttp-lwt-unix): New variable.
> ---
>  gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index d9e84cd7ad..db195996c9 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7248,6 +7248,29 @@ JavaScript backend, or @code{ocaml-cohttp-mirage} for the MirageOS unikernel
>  version of the library.  All of these implementations share the same IO logic
>  from this module.")))
>  
> +(define-public ocaml-cohttp-lwt-unix
> +  (package
> +    (inherit ocaml-cohttp)
> +    (name "ocaml-cohttp-lwt-unix")
> +    (arguments `(#:package "cohttp-lwt-unix"
> +                 ;; tests require network
> +                 #:tests? #f))
> +    (propagated-inputs
> +     `(("ocaml-conduit-lwt" ,ocaml-conduit-lwt)
> +       ("ocaml-conduit-lwt-unix" ,ocaml-conduit-lwt-unix)
> +       ("ocaml-cmdliner" ,ocaml-cmdliner)
> +       ("ocaml-magic-mime" ,ocaml-magic-mime)
> +       ("ocaml-logs" ,ocaml-logs)
> +       ("ocaml-fmt" ,ocaml-fmt)
> +       ("ocaml-cohttp-lwt" ,ocaml-cohttp-lwt)
> +       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
> +       ("ocaml-lwt" ,ocaml-lwt)
> +       ("ocaml-lwt-ssl" ,ocaml-lwt-ssl)))
> +    (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
> +    (synopsis "OCaml HTTP implementation for Unix and Windows using Lwt")
> +    (description "An OCaml implementation of an HTTP client and server for
> +Unix and Windows using the Lwt concurrency library.")))

Full sentence, maybe

  This OCaml library provides an implementation of an HTTP…

Also, I don’t think Windows support should be mentioned since it’s
not supported by Guix, and it’s non-free software.  :-)
pukkamustard Aug. 8, 2021, 1:14 p.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

> Full sentence, maybe
>
>   This OCaml library provides an implementation of an HTTP…
>
> Also, I don’t think Windows support should be mentioned since 
> it’s
> not supported by Guix, and it’s non-free software.  :-)

:) done and done (in V2).
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d9e84cd7ad..db195996c9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7248,6 +7248,29 @@  JavaScript backend, or @code{ocaml-cohttp-mirage} for the MirageOS unikernel
 version of the library.  All of these implementations share the same IO logic
 from this module.")))
 
+(define-public ocaml-cohttp-lwt-unix
+  (package
+    (inherit ocaml-cohttp)
+    (name "ocaml-cohttp-lwt-unix")
+    (arguments `(#:package "cohttp-lwt-unix"
+                 ;; tests require network
+                 #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-conduit-lwt" ,ocaml-conduit-lwt)
+       ("ocaml-conduit-lwt-unix" ,ocaml-conduit-lwt-unix)
+       ("ocaml-cmdliner" ,ocaml-cmdliner)
+       ("ocaml-magic-mime" ,ocaml-magic-mime)
+       ("ocaml-logs" ,ocaml-logs)
+       ("ocaml-fmt" ,ocaml-fmt)
+       ("ocaml-cohttp-lwt" ,ocaml-cohttp-lwt)
+       ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+       ("ocaml-lwt" ,ocaml-lwt)
+       ("ocaml-lwt-ssl" ,ocaml-lwt-ssl)))
+    (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
+    (synopsis "OCaml HTTP implementation for Unix and Windows using Lwt")
+    (description "An OCaml implementation of an HTTP client and server for
+Unix and Windows using the Lwt concurrency library.")))
+
 (define-public ocaml-magic-mime
   (package
     (name "ocaml-magic-mime")