diff mbox series

[bug#49867,13/29] gnu: Add ocaml-mirage-crypto-rng.

Message ID 20210804071545.21181-13-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-mirage-crypto-rng): New variable.
---
 gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 3:42 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-mirage-crypto-rng): New variable.
> ---
>  gnu/packages/ocaml.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index f7956fe216..6af9bedc65 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -7442,6 +7442,26 @@ between various time units.")
>  as (C-like structures using @code{ocaml-cstruct}) to OCaml native numbers.")
>      (license license:isc)))
>  
> +(define-public ocaml-mirage-crypto-rng
> +  (package
> +    (inherit ocaml-mirage-crypto)
> +    (name  "ocaml-mirage-crypto-rng")
> +    (arguments `(#:package "mirage-crypto-rng"
> +                 #:test-target "."))
> +    (propagated-inputs
> +     `(("ocaml-duration" ,ocaml-duration)
> +       ("ocaml-cstruct" ,ocaml-cstruct)
> +       ("ocaml-logs" ,ocaml-logs)
> +       ("ocaml-mirage-crypto" ,ocaml-mirage-crypto)
> +       ("ocaml-mtime" ,ocaml-mtime)
> +       ("ocaml-lwt" ,ocaml-lwt)))
> +    (native-inputs
> +     `(("ocaml-ounit" ,ocaml-ounit)
> +       ("ocaml-randomconv" ,ocaml-randomconv)))
> +    (synopsis "OCaml library providing a cryptographically secure pseudorandom number generator")

Keep lines at ~80 characters.  To keep the synopsis slighty shorter,
maybe

  "Cryptographically secure pseudo-random number generator in OCaml"

WDYT?
pukkamustard Aug. 8, 2021, 11:04 a.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

> Keep lines at ~80 characters.  To keep the synopsis slighty 
> shorter,
> maybe
>
>   "Cryptographically secure pseudo-random number generator in 
>   OCaml"
>
> WDYT?

Sounds good! Fixed in V2.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f7956fe216..6af9bedc65 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7442,6 +7442,26 @@  between various time units.")
 as (C-like structures using @code{ocaml-cstruct}) to OCaml native numbers.")
     (license license:isc)))
 
+(define-public ocaml-mirage-crypto-rng
+  (package
+    (inherit ocaml-mirage-crypto)
+    (name  "ocaml-mirage-crypto-rng")
+    (arguments `(#:package "mirage-crypto-rng"
+                 #:test-target "."))
+    (propagated-inputs
+     `(("ocaml-duration" ,ocaml-duration)
+       ("ocaml-cstruct" ,ocaml-cstruct)
+       ("ocaml-logs" ,ocaml-logs)
+       ("ocaml-mirage-crypto" ,ocaml-mirage-crypto)
+       ("ocaml-mtime" ,ocaml-mtime)
+       ("ocaml-lwt" ,ocaml-lwt)))
+    (native-inputs
+     `(("ocaml-ounit" ,ocaml-ounit)
+       ("ocaml-randomconv" ,ocaml-randomconv)))
+    (synopsis "OCaml library providing a cryptographically secure pseudorandom number generator")
+    (description "@code{ocaml-mirage-crypto-rng} provides an OCaml random
+number generator interface, and implementations.")))
+
 (define-public js-of-ocaml
   (package
     (name "js-of-ocaml")