diff mbox series

[bug#49867,22/29] gnu: Add ocaml-cstruct-unix.

Message ID 20210804071545.21181-22-pukkamustard@posteo.net
State Accepted
Headers show
Series gnu: Add ocaml-cohttp-lwt-unix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Aug. 4, 2021, 7:15 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-cstruct-unix): New variable.
---
 gnu/packages/ocaml.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Xinglu Chen Aug. 5, 2021, 4:02 p.m. UTC | #1
On Wed, Aug 04 2021, pukkamustard wrote:

> * gnu/packages/ocaml.scm (ocaml-cstruct-unix): New variable.
> ---
>  gnu/packages/ocaml.scm | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 6effe1ff12..a9a4c8a684 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -3412,6 +3412,22 @@ to access C-like structures directly from OCaml.  It supports both reading and
>  writing to these structures, and they are accessed via the Bigarray module.")
>      (license license:isc)))
>  
> +(define-public ocaml-cstruct-unix
> +  (package
> +    (inherit ocaml-cstruct)
> +    (name "ocaml-cstruct-unix")
> +    (build-system dune-build-system)
> +    (arguments
> +     `(#:package "cstruct-unix"
> +       #:test-target "."))
> +    (propagated-inputs
> +     `(("ocaml-cstruct" ,ocaml-cstruct)))
> +    (synopsis "Unix variation of the @code{ocaml-cstruct} library for accessing C-like structures directly from OCaml")

Keep lines at around ~80 characters (applies to the description too).
Maybe drop the second half of the synopsis, so

  "Unix variation of the @code{ocaml-cstruct} library"

The desciption already mentions “access C-like structures directly from
OCaml.”; the synopsis of ‘ocaml-cstruct’ also mentions “Access C
structures via a camlp4 extension”.

WDYT?
pukkamustard Aug. 8, 2021, 11:24 a.m. UTC | #2
Xinglu Chen <public@yoctocell.xyz> writes:

>> +    (synopsis "Unix variation of the @code{ocaml-cstruct} 
>> library for accessing C-like structures directly from OCaml")
>
> Keep lines at around ~80 characters (applies to the description 
> too).
> Maybe drop the second half of the synopsis, so
>
>   "Unix variation of the @code{ocaml-cstruct} library"
>
> The desciption already mentions “access C-like structures 
> directly from
> OCaml.”; the synopsis of ‘ocaml-cstruct’ also mentions “Access C
> structures via a camlp4 extension”.
>
> WDYT?

I agree. Fixed in V2.

Also fixed a missing double-space in the description.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6effe1ff12..a9a4c8a684 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3412,6 +3412,22 @@  to access C-like structures directly from OCaml.  It supports both reading and
 writing to these structures, and they are accessed via the Bigarray module.")
     (license license:isc)))
 
+(define-public ocaml-cstruct-unix
+  (package
+    (inherit ocaml-cstruct)
+    (name "ocaml-cstruct-unix")
+    (build-system dune-build-system)
+    (arguments
+     `(#:package "cstruct-unix"
+       #:test-target "."))
+    (propagated-inputs
+     `(("ocaml-cstruct" ,ocaml-cstruct)))
+    (synopsis "Unix variation of the @code{ocaml-cstruct} library for accessing C-like structures directly from OCaml")
+    (description "Cstruct is a library and syntax extension to make it easier to access C-like
+structures directly from OCaml. It supports both reading and writing to these
+structures, and they are accessed via the `Bigarray` module.")
+    (license license:isc)))
+
 (define-public ocaml-hex
   (package
     (name "ocaml-hex")