diff mbox series

[bug#70858,06/32] build-system/pyproject: Remove python-coverage input.

Message ID 20240510075605.6303-6-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/android.scm (python-androguard):
  [native-inputs]: Remove python-coverage.
  [arguments]<#:phases>: Adapt 'check phase replacement.

* gnu/packages/astronomy.scm (python-asdf-astropy, python-astropy,
python-poliastro)[native-inputs]: Remove python-coverage.

* gnu/packages/bioinformatics.scm (python-ega-download-client,
python-scikit-bio, python-cooler)[native-inputs]: Remove
python-coverage.

* gnu/packages/check.scm (python-pytest-randomly,
python-pytest-flakes, python-aiounittest)[native-inputs]: Remove
python-coverage.

* gnu/packages/cpp.scm (cpplint)[native-inputs]: Remove
python-coverage.

* gnu/packages/diffoscope.scm (reprotest)[native-inputs]: Remove
python-coverage.

* gnu/packages/django.scm (python-django-haystack)[native-inputs]:
Remove python-coverage.

* gnu/packages/engineering.scm (python-scikit-rf)[native-inputs]:
Remove python-coverage.

* gnu/packages/geo.scm (python-geopy)[native-inputs]: Remove
python-coverage.

* gnu/packages/gpodder.scm (gpodder)[native-inputs]: Remove
python-coverage.

* gnu/packages/graph.scm (python-graphtools,
python-pygsp)[native-inputs]: Remove python-coverage.

* gnu/packages/jupyter.scm (python-jupyter-packaging)[native-inputs]:
Remove python-coverage.

* gnu/packages/machine-learning.scm (onnx, onnx-optimizer,
python-lightning-utilities, python-pytorch-lightning,
python-torchmetrics, python-gpytorch)[native-inputs]: Remove
python-coverage.

* gnu/packages/music.scm (python-pylast)[native-inputs]: Remove
python-coverage.

* gnu/packages/package-management.scm (python-anaconda-client,
conda)[native-inputs]: Remove python-coverage.

* gnu/packages/python-check.scm (python-vcrpy,
python-re-assert)[native-inputs]: Remove python-coverage.

* gnu/packages/python-compression.scm (python-multivolumefile,
python-pybcj, python-bcj-cffi, python-pyppmd, python-ppmd-cffi,
python-py7zr)[native-inputs]: Remove python-coverage.

* gnu/packages/python-web.scm (python-ovh, python-flask-misaka,
python-zope-interface, python-zope-hookable, python-url,
python-transaction, python-sanic, python-woob,
python-flask-combo-jsonapi)[native-inputs]: Remove python-coverage.

* gnu/packages/python-xyz.scm (python-apprise, python-arpeggio,
python-affine, python-colorful, python-lunr, python-mdit-py-plugins,
python-bidict, python-sh, python-cftime, python-can,
python-jsonargparse, python-extension-helpers, python-pyjwt,
python-virtualenv-clone, python-lsp-server, python-pikepdf,
python-tasklogger, python-notebook, python-structlog, binwalk,
python-argcomplete, python-attrs, python-yq, python-stone,
python-identify, python-nodeenv, python-anyio, python-forbiddenfruit,
python-watchgod, python-eliot, python-pem, python-scikit-build,
python-minikanren, nikola, python-verspec, python-mike)
[native-inputs]: Remove python-coverage.

* gnu/packages/simulation.scm (python-dolfin-adjoint)[native-inputs]:
Remove python-coverage.

* gnu/packages/statistics.scm (python-emcee,
python-rpy2)[native-inputs]: Remove python-coverage.

* gnu/packages/syndication.scm (rtv, tuir)[native-inputs]: Remove
python-coverage.

* gnu/packages/terminals.scm (python-halo, python-log-symbols,
python-spinners)[native-inputs]: Remove python-coverage.

* gnu/packages/textutils.scm (python-panflute)[native-inputs]: Remove
python-coverage.

* gnu/packages/version-control.scm (pre-commit)[native-inputs]: Remove
python-coverage.

* gnu/packages/web.scm (python-httpretty)[native-inputs]: Remove
python-coverage.

* gnu/packages/xml.scm (python-xmltodict)[native-inputs]: Remove
python-coverage.

Change-Id: I66b28e624aac94f1a2f6e4fae5cdb444193cd8d9
---
 gnu/packages/android.scm            |  6 +--
 gnu/packages/astronomy.scm          |  7 +--
 gnu/packages/bioinformatics.scm     |  8 ++--
 gnu/packages/check.scm              |  7 ++-
 gnu/packages/cpp.scm                |  3 +-
 gnu/packages/diffoscope.scm         |  1 -
 gnu/packages/django.scm             |  1 -
 gnu/packages/engineering.scm        |  3 +-
 gnu/packages/geo.scm                |  1 -
 gnu/packages/gpodder.scm            |  3 +-
 gnu/packages/graph.scm              |  3 +-
 gnu/packages/jupyter.scm            |  2 +-
 gnu/packages/machine-learning.scm   | 10 +---
 gnu/packages/music.scm              |  3 +-
 gnu/packages/package-management.scm |  6 +--
 gnu/packages/python-check.scm       |  5 +-
 gnu/packages/python-compression.scm | 12 ++---
 gnu/packages/python-web.scm         | 20 ++++----
 gnu/packages/python-xyz.scm         | 72 +++++++++--------------------
 gnu/packages/simulation.scm         |  1 -
 gnu/packages/statistics.scm         |  6 +--
 gnu/packages/syndication.scm        |  4 +-
 gnu/packages/terminals.scm          |  8 ++--
 gnu/packages/textutils.scm          |  1 -
 gnu/packages/version-control.scm    |  1 -
 gnu/packages/web.scm                |  3 +-
 gnu/packages/xml.scm                |  2 +-
 27 files changed, 63 insertions(+), 136 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index cbfbd6522f4..ab42f2be980 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1072,11 +1072,9 @@  (define-public python-androguard
          (replace 'check
            ;; Adapted from .travis.yml
            (lambda _
-             (invoke "nosetests" "--with-coverage" "--with-timer"
-                     "--timer-top-n" "50"))))))
+             (invoke "nosetests" "--with-timer" "--timer-top-n" "50"))))))
     (native-inputs
-     (list python-codecov python-coverage python-mock python-nose
-           python-nose-timer))
+     (list python-codecov python-mock python-nose python-nose-timer))
     (propagated-inputs
      (list python-asn1crypto
            python-colorama
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index ede10ab927a..0ff2511208d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1678,7 +1678,6 @@  (define-public python-astropy
     (native-inputs
      (list pkg-config
            python-colorlog
-           python-coverage
            python-cython-3
            python-extension-helpers
            python-h5py
@@ -2604,8 +2603,7 @@  (define-public python-poliastro
             (lambda _
               (setenv "HOME" "/tmp"))))))
     (native-inputs
-     (list python-coverage
-           python-hypothesis
+     (list python-hypothesis
            python-mypy
            python-flit-core
            python-pytest
@@ -4953,8 +4951,7 @@  (define-public python-asdf-astropy
                    (add-before 'check 'set-home-env
                      (lambda _ (setenv "HOME" "/tmp"))))))
     (native-inputs
-     (list python-coverage
-           python-h5py
+     (list python-h5py
            python-pandas
            python-pytest
            python-pytest-astropy
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4f3a3d0ba01..eabee35f70f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2766,8 +2766,7 @@  (define-public python-ega-download-client
                (("==") ">=")))))))
     (propagated-inputs (list python-htsget python-psutil python-requests
                              python-tqdm python-urllib3))
-    (native-inputs (list python-coverage
-                         python-mock
+    (native-inputs (list python-mock
                          python-pyfakefs
                          python-pytest
                          python-responses
@@ -5359,7 +5358,7 @@  (define-public python-scikit-bio
            python-requests
            python-scipy))
     (native-inputs
-     (list python-coverage python-pytest))
+     (list python-pytest))
     (home-page "https://scikit-bio.org")
     (synopsis "Data structures, algorithms and educational resources for bioinformatics")
     (description
@@ -17971,8 +17970,7 @@  (define-public python-cooler
            python-scipy
            python-simplejson))
     (native-inputs
-     (list python-coverage
-           python-hatchling
+     (list python-hatchling
            python-isort
            python-pytest
            python-pytest-cov))
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 880d3cb46f3..b7116b3f0e2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1617,8 +1617,7 @@  (define-public python-pytest-randomly
                          "not reordered "
                          "and not test_it_runs_before_stepwise "
                          "and not test_entrypoint_injection"))))))))
-    (native-inputs (list python-coverage
-                         python-factory-boy
+    (native-inputs (list python-factory-boy
                          python-faker
                          python-numpy
                          python-pytest-xdist))
@@ -2715,7 +2714,7 @@  (define-public python-pytest-flakes
              (add-installed-pythonpath inputs outputs)
              (invoke "py.test" "-vv" "-k" "not test_syntax_error"))))))
     (native-inputs
-     (list python-coverage python-pytest python-pytest-pep8))
+     (list python-pytest python-pytest-pep8))
     (propagated-inputs
      (list python-pyflakes))
     (home-page "https://github.com/fschulze/pytest-flakes")
@@ -3568,7 +3567,7 @@  (define-public python-aiounittest
                       #t)))))
     (propagated-inputs (list python-wrapt))
     (native-inputs
-     (list python-coverage python-nose))
+     (list python-nose))
     (home-page
      "https://github.com/kwarunek/aiounittest")
     (synopsis "Test asyncio code more easily")
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8a0bd62d6b6..ba2698056da 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1189,8 +1189,7 @@  (define-public cpplint
                    (setenv "GUIX_PYTHONPATH"
                            (getenv "TMP_PYTHONPATH")))))))
     (native-inputs
-     (list python-coverage
-           python-pytest
+     (list python-pytest
            python-pytest-cov
            python-pytest-runner
            python-testfixtures))
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index fd2146456d6..67567a6b310 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -269,7 +269,6 @@  (define-public reprotest
      `(("diffoscope" ,diffoscope)
        ("help2man" ,help2man)
        ("libfaketime" ,libfaketime)
-       ("python-coverage" ,python-coverage)
        ("python-docutils" ,python-docutils)
        ("python-magic " ,python-magic)
        ("python-pytest " ,python-pytest)
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4a271eaf0b5..298968d37c6 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -495,7 +495,6 @@  (define-public python-django-haystack
      (list python-django))
     (native-inputs
      (list gdal
-           python-coverage
            python-dateutil
            python-geopy
            python-mock
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 610fb53087b..2620d5272b6 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2678,8 +2678,7 @@  (define-public python-scikit-rf
                              python-pyqtgraph
                              python-qtpy
                              python-scipy))
-    (native-inputs (list python-coverage
-                         python-nbval
+    (native-inputs (list python-nbval
                          python-networkx
                          python-pytest
                          python-pytest-cov
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 69cc7e6ddc5..806120e939d 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3264,7 +3264,6 @@  (define-public python-geopy
      (list python-geographiclib))
     (native-inputs
      (list python-async-generator
-           python-coverage
            python-isort
            python-pytest
            python-pytest-aiohttp
diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index f9102d3a447..0786010471f 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -64,7 +64,6 @@  (define-public gpodder
     (build-system python-build-system)
     (native-inputs
      (list intltool
-           python-coverage
            python-minimock
            python-pytest
            python-pytest-cov
@@ -173,7 +172,7 @@  (define-public python-mygpoclient
          "1fi5x6k1mngr0iviw2s4n1f3y2x7pwqy5ivkcrjdprzvwr37f0mh"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-coverage python-minimock python-nose))
+     (list python-minimock python-nose))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index eb8aa17fdfe..f83a23dd0be 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -476,7 +476,6 @@  (define-public python-graphtools
     (native-inputs
      (list util-linux ;for lscpu
            python-anndata
-           python-coverage
            python-coveralls
            python-nose
            python-nose2
@@ -564,7 +563,7 @@  (define-public python-pygsp
                 "")))))))
     (propagated-inputs (list python-numpy python-scikit-image python-scipy))
     (native-inputs
-     (list python-coverage python-coveralls python-pytest))
+     (list python-coveralls python-pytest))
     (home-page "https://github.com/epfl-lts2/pygsp")
     (synopsis "Graph Signal Processing in Python")
     (description "The PyGSP is a Python package to ease signal processing on
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index e2bef079ba0..456b0544a9a 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -486,7 +486,7 @@  (define-public python-jupyter-packaging
      (list python-deprecation python-packaging python-setuptools
            python-tomlkit python-wheel))
     (native-inputs
-     (list python-pypa-build python-coverage python-pytest
+     (list python-pypa-build python-pytest
            python-pytest-cov python-pytest-mock))
     (home-page "https://jupyter.org")
     (synopsis "Jupyter packaging utilities")
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b4f0f65c837..e6f6bfe410d 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1364,7 +1364,6 @@  (define args
      (list cmake
            googletest
            pybind11
-           python-coverage
            python-nbval
            python-pytest
            python-pytest-runner))
@@ -1443,8 +1442,7 @@  (define-public onnx-optimizer
         #~(modify-phases #$phases
             (delete 'relax-requirements)))))
     (native-inputs
-     (list cmake python-pytest python-pytest-runner python-nbval
-           python-coverage))
+     (list cmake python-pytest python-pytest-runner python-nbval))
     (inputs
      (list onnx protobuf pybind11))
     (propagated-inputs
@@ -4487,7 +4485,6 @@  (define-public python-lightning-utilities
     (build-system python-build-system)
     (propagated-inputs (list python-importlib-metadata python-packaging
                              python-typing-extensions))
-    (native-inputs (list python-coverage))
     (home-page "https://github.com/Lightning-AI/utilities")
     (synopsis "PyTorch Lightning sample project")
     (description "This package provides common Python utilities and GitHub
@@ -4700,7 +4697,6 @@  (define-public python-pytorch-lightning
     (native-inputs
      (list python-aiohttp
            python-cloudpickle
-           python-coverage
            python-flaky
            python-pympler
            python-pytest
@@ -4730,7 +4726,6 @@  (define-public python-torchmetrics
            python-typing-extensions))
     (native-inputs
      (list python-cloudpickle
-           python-coverage
            python-fire
            python-mir-eval
            python-mypy
@@ -5131,8 +5126,7 @@  (define-public python-gpytorch
            #~(list "-k" (string-append "not test_deprecated_methods"
                                        " and not test_t_matmul_matrix"))))
     (propagated-inputs (list python-linear-operator python-scikit-learn))
-    (native-inputs (list python-coverage
-                         python-flake8-print
+    (native-inputs (list python-flake8-print
                          python-nbval
                          python-pytest
                          python-setuptools
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3af2b79b419..5420a140657 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4069,8 +4069,7 @@  (define-public python-pylast
     ;; https://github.com/pylast/pylast/issues/105
     (arguments '(#:tests? #f))
     (native-inputs
-     (list python-coverage python-pytest python-flaky python-pyyaml
-           python-setuptools-scm))
+     (list python-pytest python-flaky python-pyyaml python-setuptools-scm))
     (home-page "https://github.com/pylast/pylast")
     (synopsis "Python interface to Last.fm and Libre.fm")
     (description "A Python interface to Last.fm and other API-compatible
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index feed16ebcef..4e7e46bf1b3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1100,8 +1100,7 @@  (define-public python-anaconda-client
      (list python-clyent python-nbformat python-pyyaml python-requests
            python-setuptools))
     (native-inputs
-     (list python-coverage
-           python-dateutil
+     (list python-dateutil
            python-freezegun
            python-mock
            python-pillow
@@ -1286,8 +1285,7 @@  (define-public conda
            ;; XXX: This is dragged in by libarchive and is needed at runtime.
            zstd))
     (native-inputs
-     (list python-coverage
-           python-flaky
+     (list python-flaky
            python-pytest-timeout
            python-pytest-xprocess
            python-wheel))
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 83fd723d12b..574a93782ce 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -411,8 +411,7 @@  (define-public python-vcrpy
     (propagated-inputs
      (list python-pyyaml python-six python-wrapt python-yarl))
     (native-inputs
-     (list python-coverage
-           python-flake8
+     (list python-flake8
            python-flask
            python-httplib2
            python-ipaddress
@@ -1145,7 +1144,7 @@  (define-public python-re-assert
            (lambda _
              (invoke "pytest" "-vv"))))))
     (native-inputs
-     (list python-covdefaults python-coverage python-pytest))
+     (list python-covdefaults python-pytest))
     (propagated-inputs
      (list python-regex))
     (home-page "https://github.com/asottile/re-assert")
diff --git a/gnu/packages/python-compression.scm b/gnu/packages/python-compression.scm
index 34a9cd73a20..b2d789c92d0 100644
--- a/gnu/packages/python-compression.scm
+++ b/gnu/packages/python-compression.scm
@@ -109,7 +109,6 @@  (define-public python-multivolumefile
     (build-system pyproject-build-system)
     (native-inputs
      (list python-setuptools-scm
-           python-coverage
            python-coveralls
            python-hypothesis
            python-pyannotate
@@ -247,8 +246,7 @@  (define-public python-pybcj
     (build-system pyproject-build-system)
     (propagated-inputs (list python-importlib-metadata))
     (native-inputs
-     (list python-coverage
-           python-hypothesis
+     (list python-hypothesis
            python-pytest
            python-pytest-cov
            python-setuptools-scm
@@ -281,8 +279,7 @@  (define-public python-bcj-cffi
     (propagated-inputs
      (list python-cffi python-toml python-setuptools-scm))
     (native-inputs
-     (list python-setuptools python-coverage python-pytest
-           python-pytest-cov))
+     (list python-setuptools python-pytest python-pytest-cov))
     (home-page "https://github.com/miurahr/bcj-cffi")
     (synopsis "Branch / Call /Jump CFFI library in Python")
     (description "This package provides an implementation of the Branch / Call /
@@ -407,8 +404,7 @@  (define-public python-pyppmd
                 "03w4x26mar0ha73c3v39psn1i0k6xrzwmaxfsxysic73jz99np07"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage
-           python-hypothesis
+     (list python-hypothesis
            python-pytest
            python-pytest-benchmark
            python-pytest-cov
@@ -441,7 +437,6 @@  (define-public python-ppmd-cffi
     (native-inputs
      (list python-hypothesis
            python-setuptools-scm
-           python-coverage
            python-pytest
            python-pytest-cov))
     (home-page "https://github.com/miurahr/ppmd")
@@ -479,7 +474,6 @@  (define-public python-py7zr
      (list python-setuptools
            python-wheel
            python-setuptools-scm
-           python-coverage
            python-coveralls
            python-libarchive-c
            python-py-cpuinfo
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4cf064e0742..942999f6cf9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -977,8 +977,7 @@  (define-public python-ovh
     (build-system pyproject-build-system)
     (arguments (list #:tests? #f))      ; XXX: tests require networking
     (propagated-inputs (list python-requests))
-    (native-inputs (list python-coverage
-                         python-isort
+    (native-inputs (list python-isort
                          python-pytest
                          python-pytest-cov
                          python-setuptools
@@ -1856,7 +1855,7 @@  (define-public python-flask-misaka
             "12gm6hq3lvlj0ddw8p6lk5pky8jk3pw758ihffjl49shnnzc68zl"))))
     (build-system python-build-system)
     (native-inputs
-      (list python-coverage python-mock))
+      (list python-mock))
     (propagated-inputs
       (list python-flask python-misaka))
     (home-page "https://github.com/singingwolfboy/flask-misaka/")
@@ -2999,8 +2998,7 @@  (define-public python-zope-interface
     (build-system python-build-system)
     (arguments '(#:tests? #f))  ; test suite can't find python-zope-testing
     (native-inputs
-     (list python-coverage python-nose python-zope-event
-           python-zope-testing))
+     (list python-nose python-zope-event python-zope-testing))
     (home-page "https://github.com/zopefoundation/zope.interface")
     (synopsis "Python implementation of the \"design by contract\"
 methodology")
@@ -3293,7 +3291,7 @@  (define-public python-zope-hookable
           "0hc82lfr7bk53nvbxvjkibkarngyrzgfk2i6bg8wshl0ly0pdl19"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-coverage python-zope-testing))
+     (list python-zope-testing))
     (home-page "https://github.com/zopefoundation/zope.hookable")
     (synopsis "Zope hookable")
     (description "This package supports the efficient creation of hookable
@@ -4500,7 +4498,7 @@  (define-public python-url
     (propagated-inputs
      (list python-publicsuffix))
     (native-inputs
-     (list python-coverage python-nose))
+     (list python-nose))
     (arguments
      `(#:tests? #f)) ; FIXME: tests fail with "ImportError: No module named 'tests'"
     (home-page "https://github.com/seomoz/url-py")
@@ -7162,7 +7160,7 @@  (define-public python-transaction
     (propagated-inputs
      (list python-zope-interface))
     (native-inputs
-     (list python-coverage python-mock python-nose))
+     (list python-mock python-nose))
     (home-page "https://github.com/zopefoundation/transaction")
     (synopsis "Transaction management for Python")
     (description "This package contains a generic transaction implementation
@@ -7624,7 +7622,6 @@  (define-public python-sanic
      (list python-bandit
            python-beautifulsoup4
            python-chardet
-           python-coverage
            python-cryptography
            python-docutils
            python-mypy
@@ -8323,7 +8320,7 @@  (define-public python-woob
            python-six
            python-unidecode))
     (native-inputs
-     (list python-coverage python-nose python-selenium python-xunitparser))
+     (list python-nose python-selenium python-xunitparser))
     (home-page "https://woob.tech/")
     (synopsis "Woob, Web Outside Of Browsers")
     (description "Woob is a collection of applications able to interact with
@@ -8372,8 +8369,7 @@  (define-public python-flask-combo-jsonapi
            python-simplejson
            python-six))
     (native-inputs
-     (list python-coverage
-           python-coveralls
+     (list python-coveralls
            python-pytest
            python-pytest-runner))
     (home-page "https://github.com/AdCombo/flask-combo-jsonapi")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa77102857c..e84ce7df3eb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -318,7 +318,6 @@  (define-public python-apprise
                              python-requests
                              python-requests-oauthlib))
     (native-inputs (list python-babel
-                         python-coverage
                          python-cryptography
                          python-paho-mqtt
                          python-pytest
@@ -1020,7 +1019,7 @@  (define-public python-affine
                (base32
                 "1shyvajayyzbkp9dihb4mz835jnkp0kqqbyjfqci6v43da6q2kd2"))))
     (build-system pyproject-build-system)
-    (propagated-inputs (list python-coveralls python-flake8 python-pydocstyle
+    (propagated-inputs (list python-coveralls python-pydocstyle
                              python-pytest python-pytest-cov))
     (native-inputs (list python-flit-core))
     (home-page "https://github.com/rasterio/affine")
@@ -1182,7 +1181,7 @@  (define-public python-colorful
         (base32 "0kyy9qhvrb5m9h8xmri7c88i0k1g5qc7017anw39gx44an7mn33y"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-pytest python-setuptools python-wheel))
+     (list python-pytest python-setuptools python-wheel))
     (propagated-inputs
      (list python-colorama))
     (home-page "http://github.com/timofurrer/colorful")
@@ -1306,8 +1305,7 @@  (define-public python-lunr
       '(list "-k" "not TestLanguageSupport"
              "--ignore-glob=tests/acceptance_tests/*")))
     (native-inputs
-     (list python-coverage
-           python-hatch-fancy-pypi-readme
+     (list python-hatch-fancy-pypi-readme
            python-hatchling
            python-pytest
            python-pytest-timeout
@@ -1340,8 +1338,7 @@  (define-public python-mdit-py-plugins
      (list python-markdown-it-py
            python-attrs))
     (native-inputs
-     (list python-coverage
-           python-flit-core
+     (list python-flit-core
            python-pytest
            python-pytest-cov
            python-pytest-regressions))
@@ -2689,8 +2686,7 @@  (define-public python-bidict
          "02dy0b1k7qlhn7ajyzkrvxhyhjj0hzcq6ws3zjml9hkdz5znz92g"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-coverage
-           python-hypothesis
+     (list python-hypothesis
            python-py
            python-pytest
            python-pytest-benchmark
@@ -3053,8 +3049,6 @@  (define-public python-sh
              ;; XXX: A Python 2 test fails when HOME=/homeless-shelter.
              (setenv "HOME" "/tmp")
              (invoke "python" "sh.py" "test"))))))
-    (native-inputs
-     (list python-coverage))
     (home-page "https://github.com/amoffat/sh")
     (synopsis "Python subprocess replacement")
     (description "This package provides a replacement for Python's
@@ -3076,7 +3070,6 @@  (define-public python-cftime
      (list python-numpy))
     (native-inputs
      (list python-check-manifest
-           python-coverage
            python-coveralls
            python-cython
            python-pytest-cov
@@ -3581,7 +3574,6 @@  (define-public python-can
     (native-inputs
      (list ;; python-canalystii ; Not packed yet
            python-codecov
-           python-coverage
            python-future
            python-hypothesis
            python-mock
@@ -4519,7 +4511,6 @@  (define-public python-jsonargparse
            python-typeshed-client))
     (native-inputs
      (list python-attrs
-           python-coverage
            python-pycodestyle
            python-pydantic
            python-pytest
@@ -5047,8 +5038,7 @@  (define-public python-extension-helpers
   ;;  - _pytest.pathlib.ImportPathMismatchError: ('extension_helpers.conftes
   (arguments (list #:tests? #f))
   (native-inputs
-    (list python-coverage
-          python-pytest
+    (list python-pytest
           python-pytest-astropy
           python-pytest-cov
           python-setuptools-scm
@@ -6008,8 +5998,7 @@  (define-public python-pyjwt
          "1z85kwr945rbzrn5wabrsmck5x8disa9wc7b3y5gci7w65z5qa39"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage
-           python-cryptography
+     (list python-cryptography
            python-pytest
            python-sphinx
            python-sphinx-rtd-theme
@@ -6237,7 +6226,6 @@  (define-public python-virtualenv-clone
     (native-inputs (list python-pytest
                          python-tox
                          python-virtualenv
-                         python-coverage
                          python-wheel
                          python-tomli
                          python-hypothesis))
@@ -8202,7 +8190,6 @@  (define-public python-lsp-server
     (native-inputs
      (list python-autopep8
            python-flake8
-           python-coverage
            python-flaky
            python-matplotlib
            python-numpy
@@ -10212,7 +10199,6 @@  (define-public python-pikepdf
     (native-inputs
      (list pybind11
            python-attrs
-           python-coverage
            python-hypothesis
            python-setuptools-scm
            python-psutil
@@ -16044,7 +16030,7 @@  (define-public python-tasklogger
         (base32 "1901mibcp6aiyjy8afnybrxnb0dkbdxlbvjqbr3gginlw7dr18xh"))))
     (build-system pyproject-build-system)
     (propagated-inputs (list python-deprecated))
-    (native-inputs (list python-coverage python-coveralls python-nose2
+    (native-inputs (list python-coveralls python-nose2
                          python-numpy python-setuptools python-wheel))
     (home-page "https://github.com/scottgigante/tasklogger")
     (synopsis "Extension to the core Python logging library")
@@ -17600,8 +17586,7 @@  (define-public python-notebook
            python-tornado-6
            python-traitlets))
     (native-inputs
-     (list python-coverage
-           python-jupyter-server
+     (list python-jupyter-server
            python-nbval
            python-pytest
            python-pytest-cov
@@ -18363,7 +18348,6 @@  (define-public python-structlog
            python-hatch-vcs
            python-hatchling
            ;; For the tests
-           python-coverage
            python-freezegun
            python-pretend
            python-pytest
@@ -22685,7 +22669,7 @@  (define-public binwalk
            (lambda _
              (setenv "HOME" ""))))))
     (native-inputs
-     (list python-coverage python-nose))
+     (list python-nose))
     (home-page "https://github.com/ReFirmLabs/binwalk")
     (synopsis "Firmware analysis tool")
     (description "Binwalk is a tool for analyzing, reverse engineering, and
@@ -23269,8 +23253,7 @@  (define-public python-argcomplete
                   "def __disable_test_console_script"))
                (invoke "python3" "./test/test.py" "-v")))))))
     (native-inputs
-     (list python-coverage
-           python-pexpect
+     (list python-pexpect
            python-setuptools
            python-setuptools-scm
            python-wheel
@@ -26263,7 +26246,7 @@  (define-public python-yq
     (inputs
      (list python-argcomplete python-pyyaml python-xmltodict python-toml jq))
     (native-inputs
-     (list python-coverage python-setuptools-scm python-wheel))
+     (list python-setuptools-scm python-wheel))
     (home-page "https://github.com/kislyuk/yq")
     (synopsis "Command-line YAML/XML processor")
     (description
@@ -27332,7 +27315,7 @@  (define-public python-stone
     (propagated-inputs
      (list python-ply python-six))
     (native-inputs
-     (list python-coverage python-mock python-pytest python-pytest-runner))
+     (list python-mock python-pytest python-pytest-runner))
     (home-page "https://github.com/dropbox/stone")
     (synopsis "Official Api Spec Language for Dropbox")
     (description
@@ -27588,8 +27571,7 @@  (define-public python-identify
                    ;; system-error "utime" "~A" ("No such file or directory")
                    (delete 'ensure-no-mtimes-pre-1980))))
     (native-inputs
-     (list python-coverage python-pytest python-setuptools
-           python-ukkonen python-wheel))
+     (list python-pytest python-setuptools python-ukkonen python-wheel))
     (propagated-inputs
      (list python-editdistance))
     (home-page "https://github.com/chriskuehl/identify")
@@ -27685,8 +27667,7 @@  (define-public python-nodeenv
                          "not test_smoke"
                          " and not test_smoke_n_system_special_chars"))))
     (native-inputs
-     (list python-coverage python-mock python-pytest
-           python-setuptools python-wheel))
+     (list python-mock python-pytest python-setuptools python-wheel))
     (home-page "https://ekalinin.github.io/nodeenv/")
     (synopsis "Create isolated node.js environments")
     (description
@@ -30039,7 +30020,6 @@  (define-public python-anyio
            python-typing-extensions))
     (native-inputs
      (list python-contextlib2
-           python-coverage
            python-hypothesis
            python-mock
            python-pytest
@@ -30405,7 +30385,7 @@  (define-public python-forbiddenfruit
            (lambda _
              (invoke "make" "SKIP_DEPS=1"))))))
     (native-inputs
-     (list python-nose python-coverage))
+     (list python-nose))
     (home-page "https://github.com/clarete/forbiddenfruit")
     (synopsis "Patch python built-in objects")
     (description "This project allows Python code to extend built-in types.")
@@ -30583,7 +30563,6 @@  (define-public python-watchgod
                                "-k" "not test_watch_log and not test_awatch")))
     (native-inputs
      (list python-anyio
-           python-coverage
            python-pygments
            python-pytest
            python-pytest-asyncio
@@ -31377,8 +31356,7 @@  (define-public python-eliot
      (list python-boltons python-pyrsistent python-six
            python-zope-interface))
     (native-inputs
-     (list python-coverage
-           python-dask
+     (list python-dask
            python-hypothesis
            python-pytest
            python-setuptools
@@ -31410,7 +31388,6 @@  (define-public python-pem
     (build-system python-build-system)
     (native-inputs
      (list python-certifi
-           python-coverage
            python-pretend
            python-pyopenssl
            python-pytest
@@ -33404,7 +33381,6 @@  (define-public python-scikit-build
            gfortran
            git-minimal/pinned           ;for tests
            ninja
-           python-coverage
            python-cython
            python-hatchling
            python-hatch-fancy-pypi-readme
@@ -34131,8 +34107,7 @@  (define-public python-minikanren
            python-pytest-cov
            python-pylint
            python-sympy
-           python-versioneer
-           python-coverage))
+           python-versioneer))
     (propagated-inputs
      (list python-toolz python-cons python-multipledispatch
            python-etuples python-logical-unification))
@@ -35075,8 +35050,7 @@  (define-public nikola
             python-unidecode
             python-yapsy))
     (native-inputs
-      (list python-coverage
-            python-freezegun
+      (list python-freezegun
             python-pytest
             python-pytest-cov))
     (arguments
@@ -35542,8 +35516,7 @@  (define-public python-verspec
                (base32
                 "07n06wv85fm4vl1ird2mja0823js3x322wgs9gdnq1djjyk4ql64"))))
     (build-system python-build-system)
-    (native-inputs (list python-coverage python-mypy
-                         python-pretend python-pytest))
+    (native-inputs (list python-mypy python-pretend python-pytest))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'check
@@ -35941,7 +35914,7 @@  (define-public python-mike
                 "0yxp816x7s948xsd0fifvq9shg01xdxlifd9rzf5y2rd9iwz3hsn"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-coverage python-shtab))
+     (list python-shtab))
     (propagated-inputs
      (list python-jinja2 python-mkdocs python-pyyaml python-verspec))
     (home-page "https://github.com/jimporter/mike")
@@ -35963,8 +35936,7 @@  (define-public python-arpeggio
                (base32
                 "0ggdsck1wpladd5bh9drhkmm86bblgk2wagrhn3sdf4v04wkic6n"))))
     (build-system python-build-system)
-    (native-inputs (list python-coverage
-                         python-coveralls
+    (native-inputs (list python-coveralls
                          python-mike
                          python-mkdocs
                          python-pytest
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 7831802284f..18d97ae44eb 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1218,7 +1218,6 @@  (define-public python-dolfin-adjoint
      (list fenics openmpi pybind11))
     (native-inputs
      (list pkg-config
-           python-coverage
            python-decorator
            python-pkgconfig
            python-pytest))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0a6f61e2280..bfc69062587 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2396,8 +2396,7 @@  (define-public python-emcee
         (base32 "1vbz67cwzig28dlndkm6g246p1vcvj6yy2w65z8cdyffigf1j3lf"))))
     (build-system pyproject-build-system)
     (propagated-inputs (list python-numpy))
-    (native-inputs (list python-coverage
-                         python-pytest
+    (native-inputs (list python-pytest
                          python-pytest-cov
                          python-setuptools
                          python-setuptools-scm
@@ -6777,8 +6776,7 @@  (define-public python-rpy2
            python-numpy
            zlib))
     (native-inputs
-     (list python-coverage
-           python-ipython
+     (list python-ipython
            python-numpy
            python-pandas
            python-pytest
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 29febdf3453..0a6ff765c30 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -435,7 +435,6 @@  (define-public rtv
     (native-inputs
      (list ncurses
            python-coveralls
-           python-coverage
            python-mock
            python-pytest
            python-vcrpy))
@@ -468,8 +467,7 @@  (define-public tuir
      (list python-beautifulsoup4 python-decorator python-kitchen
            python-requests python-six))
     (native-inputs
-     (list python-coverage
-           python-coveralls
+     (list python-coveralls
            python-mock
            python-pytest
            python-vcrpy
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 26af13af498..e96ee664eff 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1196,7 +1196,7 @@  (define-public python-halo
     (build-system pyproject-build-system)
     (propagated-inputs (list python-colorama python-log-symbols python-six
                              python-spinners python-termcolor))
-    (native-inputs (list python-coverage python-nose python-tox
+    (native-inputs (list python-nose python-tox
                          python-twine python-setuptools python-wheel))
     (home-page "https://github.com/manrajgrover/halo")
     (synopsis "Python library to display graphical spinners in the terminal")
@@ -1224,8 +1224,7 @@  (define-public python-log-symbols
                      (("(.*)==(.*)$" _ dep ver)
                       (string-append dep ">=" ver))))))))
     (propagated-inputs (list python-colorama))
-    (native-inputs (list python-coverage python-nose
-                         python-setuptools python-tox python-wheel))
+    (native-inputs (list python-nose python-setuptools python-tox python-wheel))
     (home-page "https://github.com/manrajgrover/py-log-symbols")
     (synopsis "Python library with graphical symbols for logging on the terminal")
     (description "This package provides a Python library with graphical symbols
@@ -1252,8 +1251,7 @@  (define-public python-spinners
                    (substitute* "requirements-dev.txt"
                      (("(.*)==(.*)$" _ dep ver)
                       (string-append dep ">=" ver))))))))
-    (native-inputs (list python-coverage python-nose
-                         python-setuptools python-tox python-wheel))
+    (native-inputs (list python-nose python-setuptools python-tox python-wheel))
     (home-page "https://github.com/manrajgrover/py-spinners")
     (synopsis "Python library with graphical spinners for the terminal")
     (description "Spinners is a Python library that contains graphical spinners
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index bf2da58a3ee..2c7fd0365ca 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1674,7 +1674,6 @@  (define-public python-panflute
     (build-system python-build-system)
     (propagated-inputs (list python-click python-pyyaml))
     (native-inputs (list python-configparser
-                         python-coverage
                          python-pandocfilters
                          python-pytest
                          python-pytest-cov
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index bccc219f679..f85e8b274cb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2064,7 +2064,6 @@  (define-public pre-commit
     (native-inputs
      (list git-minimal
            python-covdefaults
-           python-coverage
            python-distlib
            python-pytest
            python-pytest-env
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c29a8b3ca7b..736be82c90b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6893,8 +6893,7 @@  (define-public python-httpretty
              (when tests?
                (invoke "nosetests")))))))
     (native-inputs
-     (list python-coverage
-           python-eventlet
+     (list python-eventlet
            python-nose
            python-rednose
            python-requests
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2654f688d4b..1f767ba69b2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1950,7 +1950,7 @@  (define-public python-xmltodict
          "08cadlb9vsb4pmzc99lz3a2lx6qcfazyvgk10pcqijvyxlwcdn2h"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-nose python-setuptools python-wheel))
+     (list python-nose python-setuptools python-wheel))
     (home-page "https://github.com/martinblech/xmltodict")
     (synopsis "Work with XML like you are working with JSON")
     (description "This package provides a Python library to convert XML to