diff mbox series

[bug#70858,04/32] build-system/pyproject: Remove python-pylint native-input.

Message ID 20240510075605.6303-4-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/potassco.scm (python-clingraph):
  [native-inputs]: Remove python-pylint.

* gnu/packages/python-xyz.scm (python-mediapy, python-fastjsonschema,
python-trio)[native-inputs]: Remove python-pylint.

* gnu/packages/syndication.scm (rtv, tuir)[native-inputs]: Remove
python-pylint.

* gnu/packages/terminals.scm (python-halo, python-log-symbols,
python-spinners)[native-inputs]: Remove python-pylint.

Change-Id: If6a20e0b790f7157013a6868bba9e4a8d7e5ba28
---
 gnu/packages/potassco.scm    | 3 +--
 gnu/packages/python-xyz.scm  | 3 ---
 gnu/packages/syndication.scm | 2 --
 gnu/packages/terminals.scm   | 6 +++---
 4 files changed, 4 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 9af307b4a90..054f9e9b180 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -563,8 +563,7 @@  (define-public python-clingraph
                              python-jsonschema
                              python-networkx
                              python-setuptools))
-    (native-inputs (list dot2tex graphviz python-pylint python-pytest
-                         python-wheel))
+    (native-inputs (list dot2tex graphviz python-pytest python-wheel))
     (home-page "https://github.com/potassco/clingraph")
     (synopsis "Visualizer for graphs defined as logic programs")
     (description
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7eff059637e..e558dcdc83a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4440,7 +4440,6 @@  (define-public python-mediapy
                              python-pillow))
     (native-inputs
      (list python-flit-core
-           python-pylint
            python-pytest
            python-pytest-xdist))
     (home-page "https://github.com/google/mediapy")
@@ -17184,7 +17183,6 @@  (define-public python-fastjsonschema
      (list python-colorama
            python-json-spec
            python-jsonschema
-           python-pylint
            python-pytest
            python-pytest-benchmark
            python-pytest-cache
@@ -29072,7 +29070,6 @@  (define-public python-trio
      (list python-astor
            python-ipython
            python-jedi
-           python-pylint
            python-pyopenssl
            python-pytest
            python-pytest-xdist
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index a2d8c61be45..29febdf3453 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -437,7 +437,6 @@  (define-public rtv
            python-coveralls
            python-coverage
            python-mock
-           python-pylint
            python-pytest
            python-vcrpy))
     (home-page "https://github.com/michael-lazar/rtv")
@@ -472,7 +471,6 @@  (define-public tuir
      (list python-coverage
            python-coveralls
            python-mock
-           python-pylint
            python-pytest
            python-vcrpy
            python-setuptools
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 98a6bf6684a..26af13af498 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1196,7 +1196,7 @@  (define-public python-halo
     (build-system pyproject-build-system)
     (propagated-inputs (list python-colorama python-log-symbols python-six
                              python-spinners python-termcolor))
-    (native-inputs (list python-coverage python-nose python-pylint python-tox
+    (native-inputs (list python-coverage python-nose python-tox
                          python-twine python-setuptools python-wheel))
     (home-page "https://github.com/manrajgrover/halo")
     (synopsis "Python library to display graphical spinners in the terminal")
@@ -1224,7 +1224,7 @@  (define-public python-log-symbols
                      (("(.*)==(.*)$" _ dep ver)
                       (string-append dep ">=" ver))))))))
     (propagated-inputs (list python-colorama))
-    (native-inputs (list python-coverage python-nose python-pylint
+    (native-inputs (list python-coverage python-nose
                          python-setuptools python-tox python-wheel))
     (home-page "https://github.com/manrajgrover/py-log-symbols")
     (synopsis "Python library with graphical symbols for logging on the terminal")
@@ -1252,7 +1252,7 @@  (define-public python-spinners
                    (substitute* "requirements-dev.txt"
                      (("(.*)==(.*)$" _ dep ver)
                       (string-append dep ">=" ver))))))))
-    (native-inputs (list python-coverage python-nose python-pylint
+    (native-inputs (list python-coverage python-nose
                          python-setuptools python-tox python-wheel))
     (home-page "https://github.com/manrajgrover/py-spinners")
     (synopsis "Python library with graphical spinners for the terminal")