diff mbox series

[bug#70858,03/32] build-system/pyproject: Remove python-black input.

Message ID 20240510075605.6303-3-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/bioinformatics.scm (python-doubletdetection,
python-liana-py, scvelo)[native-inputs]: Remove python-black.

* gnu/packages/databases.scm (datasette):
  [arguments]<#:test-flags>: Ignore black tests.
  <#:phases>: Remove parts related to black in relax-requirements
  added phase.
  [native-inputs]: Remove python-black.

* gnu/packages/finance.scm (python-trezor)[native-inputs]: Remove
python-black.

* gnu/packages/graph.scm (python-graphtools)[native-inputs]: Remove
python-black.

* gnu/packages/machine-learning.scm (python-funsor,
python-imbalanced-learn, python-hyperopt, python-captum,
python-pyro-ppl)[native-inputs]: Remove python-black.

* gnu/packages/python-check.scm (python-vcrpy)[native-inputs]:
Remove python-black.

* gnu/packages/python-web.scm (python-ovh, python-openai,
python-starsessions-for-pytorch-lightning)[native-inputs]: Remove
python-black.

* gnu/packages/python-xyz.scm (python-pydantic-cli, python-imageio,
python-update-checker, python-eliot, python-minikanren,
python-jupytext)[native-inputs]: Remove python-black.
(ptpython)[propagated-inputs]: Remove python-black.

* gnu/packages/virtualization.scm (python-transient)[native-inputs]:
Remove python-black.

Change-Id: Ie8098afda264bf9a5ab2cfe5d915bc7a41fdc604
---
 gnu/packages/bioinformatics.scm   | 11 +++--------
 gnu/packages/databases.scm        |  8 ++------
 gnu/packages/finance.scm          |  1 -
 gnu/packages/graph.scm            |  1 -
 gnu/packages/machine-learning.scm | 11 +++--------
 gnu/packages/python-check.scm     |  3 +--
 gnu/packages/python-web.scm       |  8 +++-----
 gnu/packages/python-xyz.scm       | 15 +++++----------
 gnu/packages/virtualization.scm   |  2 +-
 9 files changed, 18 insertions(+), 42 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a611caf715a..253c36947c3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2152,8 +2152,7 @@  (define-public python-doubletdetection
            python-scipy
            python-tqdm))
     (native-inputs
-     (list python-black
-           python-flake8
+     (list python-flake8
            python-poetry-core
            python-pytest))
     (home-page "https://github.com/JonathanShor/DoubletDetection")
@@ -2278,10 +2277,7 @@  (define-public python-liana-py
                              python-tqdm
                              tzdata))
     (native-inputs
-     (list python-black
-           python-poetry-core
-           python-pytest
-           python-pytest-cov))
+     (list python-poetry-core python-pytest python-pytest-cov))
     (home-page "https://github.com/saezlab/liana-py")
     (synopsis "LIANA is a ligand-receptor analysis framework")
     (description "This is a Ligand-Receptor inference framework.  The
@@ -21837,8 +21833,7 @@  (define-public scvelo
            python-umap-learn
            pybind11))
     (native-inputs
-     (list python-black
-           python-flake8
+     (list python-flake8
            python-hypothesis
            python-pytest
            python-setuptools-scm
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 67e6ced7c32..96b2c2a0437 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5537,16 +5537,13 @@  (define-public datasette
                     " or test_custom_query_with_unicode_characters"
                     " or test_searchmode)")
               "-n" (number->string (parallel-job-count))
-              "-m" "not serial")        ;cannot run in parallel
+              "-m" "not serial"  ;cannot run in parallel
+              "--ignore=tests/test_black.py")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'relax-requirements
             (lambda _
-              ;; The package needlessly specifies exact versions
-              ;; of dependencies, when it works fine with others.
               (substitute* "setup.py"
-                (("(black)==[0-9\\.]+" _ package)
-                 package)
                 (("click-default-group-wheel")
                  "click-default-group")))))))
     (propagated-inputs
@@ -5569,7 +5566,6 @@  (define-public datasette
            python-uvicorn))
     (native-inputs
      (list python-beautifulsoup4
-           python-black
            python-cogapp
            python-pip
            python-pytest
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3c32a220c4e..7d1efde8187 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1149,7 +1149,6 @@  (define-public python-trezor
            python-typing-extensions))
     (native-inputs ; Only needed for running the tests
      (list protobuf
-           python-black
            python-isort
            python-pillow
            python-protobuf
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index eda8365a424..033027a5aa9 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -476,7 +476,6 @@  (define-public python-graphtools
     (native-inputs
      (list util-linux ;for lscpu
            python-anndata
-           python-black
            python-coverage
            python-coveralls
            python-nose
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ba6f51b3f11..e63dd0f0678 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -175,8 +175,7 @@  (define-public python-funsor
     (propagated-inputs (list python-makefun python-multipledispatch
                              python-numpy python-opt-einsum
                              python-typing-extensions))
-    (native-inputs (list python-black
-                         python-flake8
+    (native-inputs (list python-flake8
                          python-isort
                          python-nbsphinx
                          python-pandas
@@ -1923,8 +1922,7 @@  (define-public python-imbalanced-learn
                               (getcwd)))))))
     (propagated-inputs (list python-joblib python-numpy python-scikit-learn
                              python-scipy python-threadpoolctl))
-    (native-inputs (list python-black
-                         python-flake8
+    (native-inputs (list python-flake8
                          python-keras
                          python-mypy
                          python-pandas
@@ -2359,8 +2357,7 @@  (define-public python-hyperopt
            python-six
            python-tqdm))
     (native-inputs
-     (list python-black
-           python-nose
+     (list python-nose
            python-pymongo
            python-pytest
            python-wheel))
@@ -4525,7 +4522,6 @@  (define-public python-captum
      (list python-matplotlib python-numpy python-pytorch python-tqdm))
     (native-inputs (list jupyter
                          python-annoy
-                         python-black
                          python-flake8
                          python-flask
                          python-flask-compress
@@ -5063,7 +5059,6 @@  (define-public python-pyro-ppl
     (native-inputs
      (list ninja
            jupyter
-           python-black
            python-flake8
            python-graphviz
            python-isort
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5571cee2088..83fd723d12b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -411,8 +411,7 @@  (define-public python-vcrpy
     (propagated-inputs
      (list python-pyyaml python-six python-wrapt python-yarl))
     (native-inputs
-     (list python-black
-           python-coverage
+     (list python-coverage
            python-flake8
            python-flask
            python-httplib2
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61ea8a63558..a7794741f42 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -977,8 +977,7 @@  (define-public python-ovh
     (build-system pyproject-build-system)
     (arguments (list #:tests? #f))      ; XXX: tests require networking
     (propagated-inputs (list python-requests))
-    (native-inputs (list python-black
-                         python-coverage
+    (native-inputs (list python-coverage
                          python-flake8
                          python-isort
                          python-pytest
@@ -2174,7 +2173,7 @@  (define-public python-openai
  and not test_file_cli")))
     (propagated-inputs (list python-aiohttp python-requests python-tqdm
                              python-typing-extensions))
-    (native-inputs (list python-black python-pytest python-pytest-asyncio
+    (native-inputs (list python-pytest python-pytest-asyncio
                          python-pytest-mock python-setuptools python-wheel))
     (home-page "https://github.com/openai/openai-python")
     (synopsis "Python client library for the OpenAI API")
@@ -8968,8 +8967,7 @@  (define-public python-starsessions-for-pytorch-lightning
            python-itsdangerous
            python-starlette-for-fastapi-0.88))
     (native-inputs
-     (list python-black
-           python-flake8
+     (list python-flake8
            python-httpx
            python-mypy
            python-poetry-core
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f86ea8224b..7eff059637e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -478,7 +478,6 @@  (define-public python-jupytext
     (native-inputs
      (list git-minimal
            python-autopep8
-           python-black
            python-flake8
            python-gitpython
            python-isort
@@ -8029,8 +8028,7 @@  (define-public python-pydantic-cli
     (propagated-inputs
      (list python-pydantic))
     (native-inputs
-     (list python-black
-           python-mypy
+     (list python-mypy
            python-pytest))
     (home-page "https://github.com/mpkocher/pydantic-cli")
     (synopsis "Turn Pydantic defined data models into CLI tools")
@@ -10802,7 +10800,7 @@  (define-public python-imageio
     (propagated-inputs
      (list python-imageio-ffmpeg python-numpy python-pillow python-tifffile python-setuptools))
     (native-inputs
-     (list python-black python-flake8 python-fsspec python-pytest
+     (list python-flake8 python-fsspec python-pytest
            python-pytest-cov python-wheel))
     (home-page "https://imageio.github.io/")
     (synopsis "Library for reading and writing a wide range of image data")
@@ -22108,8 +22106,7 @@  (define-public ptpython
     (arguments
      `(#:tests? #f)) ;there are no tests
     (propagated-inputs
-     (list python-appdirs python-black python-jedi python-prompt-toolkit
-           python-pygments))
+     (list python-appdirs python-jedi python-prompt-toolkit python-pygments))
     (home-page "https://github.com/jonathanslenders/ptpython")
     (synopsis "Python Read-Eval-Print-Loop with nice IDE-like features")
     (description
@@ -27291,7 +27288,7 @@  (define-public python-update-checker
         (base32 "04yb5a9mi45ax50m2m0ih6gdvkk1j7gfmy83dd58i1f59axlabba"))))
     (build-system python-build-system)
     (propagated-inputs (list python-requests))
-    (native-inputs (list python-black python-flake8 python-pytest))
+    (native-inputs (list python-flake8 python-pytest))
     (home-page "https://github.com/bboe/update_checker")
     (synopsis "Python module that will check for package updates")
     (description "This package provides a Python module that will check for
@@ -31399,8 +31396,7 @@  (define-public python-eliot
      (list python-boltons python-pyrsistent python-six
            python-zope-interface))
     (native-inputs
-     (list python-black
-           python-coverage
+     (list python-coverage
            python-dask
            python-flake8
            python-hypothesis
@@ -34155,7 +34151,6 @@  (define-public python-minikanren
            python-pytest
            python-pytest-cov
            python-pylint
-           python-black
            python-sympy
            python-versioneer
            python-coverage))
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 20cbb0b8bed..b564bd043cb 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2809,7 +2809,7 @@  (define-public python-transient
            python-requests
            python-toml))
     (native-inputs
-     (list python-black python-mypy python-pyhamcrest python-twine
+     (list python-mypy python-pyhamcrest python-twine
            python-setuptools python-wheel))
     (home-page "https://github.com/ALSchwalm/transient")
     (synopsis "QEMU Wrapper written in Python")