diff mbox series

[bug#70858,29/32] build-system/pyproject: Remove python-pytest-mypy inputs.

Message ID 20240510075605.6303-29-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/astronomy.scm (python-czml3, python-poliastro)
[native-inputs]: Remove python-pytest-mypy.

* gnu/packages/check.scm (python-pytest-perf)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/python-web.scm (python-portend)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/python-xyz.scm (python-importlib-resources,
python-jaraco-classes, python-jaraco-collections,
python-jaraco-context, python-jaraco-functools, python-jaraco-test,
python-jaraco-text, python-path, python-pip-run, python-inflect,
python-tempora, python-loguru, python-portalocker)[native-inputs]: Remove
python-pytest-mypy.

* gnu/packages/sphinx.scm (python-sphinx, python-sphinx-5):
[propagated-inputs]: Remove python-mypy.

Change-Id: Ia36ca82e0327a886f9c5317e9ef4ffc35dc8ac9d
---
 gnu/packages/astronomy.scm  |  4 +---
 gnu/packages/check.scm      |  1 -
 gnu/packages/python-web.scm |  1 -
 gnu/packages/python-xyz.scm | 17 ++---------------
 gnu/packages/sphinx.scm     |  2 --
 5 files changed, 3 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 61ab7520aef..2b78738f5a8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2226,7 +2226,6 @@  (define-public python-czml3
     (native-inputs
      (list python-astropy
            python-pytest
-           python-pytest-mypy
            python-setuptools
            python-wheel))
     (home-page "https://github.com/poliastro/czml3")
@@ -2604,8 +2603,7 @@  (define-public python-poliastro
            python-flit-core
            python-pytest
            python-pytest-doctestplus
-           python-pytest-mpl
-           python-pytest-mypy))
+           python-pytest-mpl))
     (propagated-inputs
      (list python-astropy
            python-astroquery
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e8f121e9fe9..8eac2b13563 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2664,7 +2664,6 @@  (define-public python-pytest-perf
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-mypy
            python-setuptools
            python-wheel))
     (propagated-inputs
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2a7d083b9de..425aa9d5d0f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -313,7 +313,6 @@  (define-public python-portend
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/portend")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b3837dddc4..733a60b087d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4928,7 +4928,6 @@  (define-public python-portalocker
                 "0lawjm736vs86wlnxc3qqh37l11z0yx81xq3dmrw33m86kaq2bh3"))))
     (build-system pyproject-build-system)
     (native-inputs (list python-pytest
-                         python-pytest-mypy
                          python-pytest-timeout
                          python-redis
                          python-setuptools
@@ -11525,7 +11524,6 @@  (define-public python-importlib-resources
      (list python-pytest
            python-pytest-checkdocs
            python-pytest-enabler
-           python-pytest-mypy
            python-setuptools-57
            python-setuptools-scm))
     (propagated-inputs
@@ -11652,7 +11650,6 @@  (define-public python-jaraco-classes
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11684,7 +11681,6 @@  (define-public python-jaraco-collections
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.collections")
@@ -11742,7 +11738,6 @@  (define-public python-jaraco-context
     (native-inputs
      (list python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11774,7 +11769,6 @@  (define-public python-jaraco-functools
      (list python-jaraco-classes
            python-pytest
            python-pytest-checkdocs
-           python-pytest-mypy
            python-setuptools
            python-setuptools-scm
            python-wheel))
@@ -11832,7 +11826,6 @@  (define-public python-jaraco-test
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.test")
@@ -11863,7 +11856,6 @@  (define-public python-jaraco-text
     (native-inputs (list python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          python-setuptools
                          python-wheel))
     (home-page "https://github.com/jaraco/jaraco.text")
@@ -16503,8 +16495,7 @@  (define-public python-path
                python-pygments
                python-pytest
                python-pytest-checkdocs
-               python-pytest-enabler
-               python-pytest-mypy)))
+               python-pytest-enabler)))
     (properties (alist-delete 'hidden?
                               (package-properties
                                python-path-bootstrap)))))
@@ -16606,8 +16597,7 @@  (define-public python-pip-run
                python-pygments
                python-pytest
                python-pytest-checkdocs
-               python-pytest-enabler
-               python-pytest-mypy)))
+               python-pytest-enabler)))
     (properties (alist-delete 'hidden? (package-properties
                                         python-pip-run-bootstrap)))))
 
@@ -21043,7 +21033,6 @@  (define-public python-inflect
                          python-pytest
                          python-pytest-checkdocs
                          python-pytest-enabler
-                         python-pytest-mypy
                          ;; For the version number
                          python-setuptools-scm
                          python-setuptools
@@ -25891,7 +25880,6 @@  (define-public python-tempora
            python-pytest-checkdocs
            python-pytest-enabler
            python-pytest-freezegun
-           python-pytest-mypy
            python-setuptools-scm
            python-types-freezegun
            python-types-pytz
@@ -32828,7 +32816,6 @@  (define-public python-loguru
     (propagated-inputs (list python-colorama))
     (native-inputs (list python-colorama
                          python-freezegun
-                         python-mypy
                          python-pre-commit
                          python-pytest
                          python-pytest-mypy-plugins
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 669120cad0a..35eaef3036e 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -94,7 +94,6 @@  (define-public python-sphinx
            python-imagesize
            python-importlib-metadata
            python-jinja2
-           python-mypy
            python-packaging
            python-pygments
            python-requests
@@ -191,7 +190,6 @@  (define-public python-sphinx-5
            python-imagesize
            python-importlib-metadata
            python-jinja2
-           python-mypy
            python-packaging
            python-pygments
            python-requests