diff mbox series

[bug#70858,16/32] build-system/pyproject: Remove python-codecov native-input.

Message ID 20240510075605.6303-16-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/android.scm (python-androguard)[native-inputs]: Remove
python-codecov.

* gnu/packages/astronomy.scm (python-wiimatch, python-tweakwcs)
[native-inputs]: Remove python-codecov.

* gnu/packages/python-check.scm (python-pytest-trio):
  [arguments]<#:test-flags>: Remove --cov flag.
  [native-inputs]: Remove python-pytest-cov.

* gnu/packages/python-xyz.scm (python-can,
python-ddlparse)[native-inputs]: Remove python-codecov.

Change-Id: Ic7d3789b3b30d3263f61442bb4e55fd332a4d2f6
---
 gnu/packages/android.scm      | 2 +-
 gnu/packages/astronomy.scm    | 8 +++-----
 gnu/packages/python-check.scm | 5 ++---
 gnu/packages/python-xyz.scm   | 4 +---
 4 files changed, 7 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index ab42f2be980..7cc1fa4ef05 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -1074,7 +1074,7 @@  (define-public python-androguard
            (lambda _
              (invoke "nosetests" "--with-timer" "--timer-top-n" "50"))))))
     (native-inputs
-     (list python-codecov python-mock python-nose python-nose-timer))
+     (list python-mock python-nose python-nose-timer))
     (propagated-inputs
      (list python-asn1crypto
            python-colorama
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0ff2511208d..c2d874f8f3f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4605,8 +4605,7 @@  (define-public python-tweakwcs
            python-stsci-imagestats
            python-stsci-stimage))
     (native-inputs
-     (list python-codecov
-           python-pytest
+     (list python-pytest
            python-pytest-cov
            python-scipy
            python-setuptools
@@ -5272,9 +5271,8 @@  (define-public python-wiimatch
                 "15kq7z30m9i286ncs9xvpaq3dq1p5fa47jz21prq146qwr7j6dm8"))))
     (build-system pyproject-build-system)
     (propagated-inputs (list python-numpy python-scipy python-setuptools))
-    (native-inputs (list python-codecov python-pytest python-pytest-cov
-                         python-pytest-doctestplus python-setuptools-scm
-                         python-wheel))
+    (native-inputs (list python-pytest python-pytest-cov python-wheel
+                         python-pytest-doctestplus python-setuptools-scm))
     (home-page "https://github.com/spacetelescope/wiimatch")
     (synopsis
      "Optimal matching of weighted N-dimensional image intensity data")
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 3281e5a772b..5345a15e108 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1191,7 +1191,7 @@  (define-public python-pytest-trio
     (arguments
      (list
       #:test-flags '(list "-W" "error" "-ra" "-v" "--pyargs"
-                          "pytest_trio" "--verbose" "--cov" "-k"
+                          "pytest_trio" "--verbose" "-k"
                           (string-append
                            ;; Needs network
                            "not test_async_yield_fixture_with_nursery"
@@ -1199,8 +1199,7 @@  (define-public python-pytest-trio
                            ;; No keyboard interrupt in our build environment.
                            " and not test_actual_test"))))
     (native-inputs
-     (list python-hypothesis python-pytest python-pytest-cov
-           python-setuptools python-wheel))
+     (list python-hypothesis python-pytest python-setuptools python-wheel))
     (propagated-inputs
       (list python-async-generator python-outcome python-pytest python-trio))
     (home-page "https://github.com/python-trio/pytest-trio")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4167de452d..ca6d5279d19 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3572,7 +3572,6 @@  (define-public python-can
            python-setuptools))
     (native-inputs
      (list ;; python-canalystii ; Not packed yet
-           python-codecov
            python-future
            python-hypothesis
            python-mock
@@ -5675,8 +5674,7 @@  (define-public python-ddlparse
         (base32 "1nh8m6rxslwk05daxshxmgk41qfp18yynydba49b13l4m8dnh634"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-codecov
-           python-pytest
+     (list python-pytest
            python-pytest-cov
            python-setuptools
            python-tox