diff mbox series

[bug#70858,12/32] build-system/pyproject: Remove python-pycodestyle native-input.

Message ID 20240510075605.6303-12-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/python-science.scm (python-scipy):
[native-inputs]: Remove python-pycodestyle.

* gnu/packages/python-xyz.scm (python-jsonargparse, python-lsp-server,
python-orderedmultidict, python-progressbar2, python-stem)
[native-inputs]: Remove python-pycodestyle.

Change-Id: I4518bae13aa0e688bc6e0bb40c07082414e8130f
---
 gnu/packages/python-science.scm | 1 -
 gnu/packages/python-xyz.scm     | 7 ++-----
 2 files changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 9301e82bb60..e20cb56db9c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -296,7 +296,6 @@  (define-public python-scipy
            python-doit
            python-hypothesis
            python-pooch
-           python-pycodestyle
            python-pydevtool
            python-pytest
            python-pytest-cov
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c2926bf7497..18e4d21f136 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4510,7 +4510,6 @@  (define-public python-jsonargparse
            python-typeshed-client))
     (native-inputs
      (list python-attrs
-           python-pycodestyle
            python-pydantic
            python-pytest
            python-pytest-subtests
@@ -8180,7 +8179,6 @@  (define-public python-lsp-server
            python-jedi
            python-lsp-jsonrpc
            python-pluggy
-           python-pycodestyle
            python-pydocstyle
            python-ujson
            python-whatthepatch
@@ -9915,7 +9913,7 @@  (define-public python-orderedmultidict
     (propagated-inputs
      (list python-six))
     (native-inputs
-     (list python-flake8 python-pycodestyle python-setuptools python-wheel))
+     (list python-flake8 python-setuptools python-wheel))
     (home-page "https://github.com/gruns/orderedmultidict")
     (synopsis "Python Ordered Multivalue Dictionary - omdict")
     (description "This package contains a library for ordered multivalue
@@ -18660,7 +18658,6 @@  (define-public python-progressbar2
      (list python-six python-utils))
     (native-inputs
      (list python-freezegun
-           python-pycodestyle
            python-pytest
            python-pytest-cache
            python-pytest-cov
@@ -22174,7 +22171,7 @@  (define-public python-stem
              (invoke "./run_tests.py" "--unit")
              #t)))))
     (native-inputs
-     (list python-mock python-pycodestyle python-pyflakes))
+     (list python-mock python-pyflakes))
     (home-page "https://stem.torproject.org/")
     (synopsis
      "Python controller library that allows applications to interact with Tor")