diff mbox series

[bug#70858,21/32] build-system/pyproject: Remove python-twine native-input.

Message ID 20240510075605.6303-21-ngraves@ngraves.fr
State New
Headers show
Series None | expand

Commit Message

Nicolas Graves May 10, 2024, 7:55 a.m. UTC
* gnu/packages/gettext.scm (mdpo)[native-inputs]: Remove python-twine.

* gnu/packages/machine-learning.scm (python-linear-operator,
python-gpytorch)[native-inputs]: Remove python-twine.

* gnu/packages/python-check.scm (python-testfixtures)[native-inputs]:
Remove python-twine.

* gnu/packages/python-web.scm (python-translation-finder)
[native-inputs]: Remove python-twine.

* gnu/packages/python-xyz.scm (python-cftime, python-eventlet,
python-eliot, python-arpeggio)[native-inputs]: Remove python-twine.

* gnu/packages/terminals.scm (python-halo)[native-inputs]: Remove
python-twine.

* gnu/packages/virtualization.scm (python-transient)[native-inputs]:
Remove python-twine.

Change-Id: Ie9ff17126810dc3e2b17ad42a1f765361401eae7
---
 gnu/packages/gettext.scm          | 1 -
 gnu/packages/machine-learning.scm | 6 ++----
 gnu/packages/python-check.scm     | 2 +-
 gnu/packages/python-web.scm       | 2 +-
 gnu/packages/python-xyz.scm       | 6 +-----
 gnu/packages/terminals.scm        | 3 +--
 gnu/packages/virtualization.scm   | 2 +-
 7 files changed, 7 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 39215a0ccb6..b3c807c6774 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -221,7 +221,6 @@  (define-public mdpo
            python-sphinx
            python-sphinx-argparse
            python-sphinx-rtd-theme
-           python-twine
            python-yamllint))
     (propagated-inputs
      (list python-polib python-pymd4c))
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index d4ce01b0c1b..7c3faa94c5e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5093,8 +5093,7 @@  (define-public python-linear-operator
     (native-inputs (list python-flake8-print
                          python-pytest
                          python-setuptools
-                         python-setuptools-scm
-                         python-twine))
+                         python-setuptools-scm))
     (home-page "https://github.com/cornellius-gp/linear_operator/")
     (synopsis "Linear operator implementation")
     (description "LinearOperator is a PyTorch package for abstracting away the
@@ -5123,8 +5122,7 @@  (define-public python-gpytorch
     (native-inputs (list python-flake8-print
                          python-nbval
                          python-pytest
-                         python-setuptools
-                         python-twine))
+                         python-setuptools))
     (home-page "https://gpytorch.ai")
     (synopsis "Implementation of Gaussian Processes in PyTorch")
     (description
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d51c5e19bba..4426e5af2f5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -245,7 +245,7 @@  (define-public python-testfixtures
     (native-inputs
      (list python-pytest python-pytest-cov
            ;;("python-pytest-django" ,python-pytest-django)
-           python-twine python-wheel))
+           python-wheel))
     (synopsis "Tests components for Python")
     (description "Testfixtures is a collection of helpers and mock objects that
 are useful when writing automated tests in Python.")
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d4988620385..3aadc9060a0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6221,7 +6221,7 @@  (define-public python-translation-finder
      (list python-chardet python-pathlib2 python-ruamel.yaml python-six))
     (native-inputs
      (list python-codecov python-codacy-coverage python-pytest-cov
-           python-pytest-runner python-twine))
+           python-pytest-runner))
     (home-page "https://weblate.org/")
     (synopsis "Translation file finder for Weblate")
     (description "This package provides a function to find translation file in
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f467f5f5794..4e6f0e1a29a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3070,7 +3070,6 @@  (define-public python-cftime
            python-cython
            python-pytest-cov
            python-sphinx
-           python-twine
            python-wheel))
     (home-page "https://unidata.github.io/cftime/")
     (synopsis "Library for time handling")
@@ -4240,8 +4239,7 @@  (define-public python-eventlet
      (list python-black
            python-hatchling
            python-hatch-vcs
-           python-pytest
-           python-twine))
+           python-pytest))
     (arguments
      (list
       #:test-flags
@@ -31340,7 +31338,6 @@  (define-public python-eliot
            python-sphinx
            python-sphinx-rtd-theme
            python-testtools
-           python-twine
            python-twisted))
     (home-page "https://github.com/itamarst/eliot/")
     (synopsis "Eliot: the logging system that tells you why it happened")
@@ -35908,7 +35905,6 @@  (define-public python-arpeggio
                          python-mkdocs
                          python-pytest
                          python-pytest-runner
-                         python-twine
                          python-wheel))
     (home-page "https://github.com/textX/Arpeggio")
     (synopsis "Packrat parser interpreter for Python")
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index a0acaa71769..6a1946719a6 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1196,8 +1196,7 @@  (define-public python-halo
     (build-system pyproject-build-system)
     (propagated-inputs (list python-colorama python-log-symbols python-six
                              python-spinners python-termcolor))
-    (native-inputs (list python-nose
-                         python-twine python-setuptools python-wheel))
+    (native-inputs (list python-nose python-setuptools python-wheel))
     (home-page "https://github.com/manrajgrover/halo")
     (synopsis "Python library to display graphical spinners in the terminal")
     (description "Halo is a Python library to display graphical spinners in
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 90f46e6f23a..cf090aec9fc 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2808,7 +2808,7 @@  (define-public python-transient
            python-requests
            python-toml))
     (native-inputs
-     (list python-pyhamcrest python-twine python-setuptools python-wheel))
+     (list python-pyhamcrest python-setuptools python-wheel))
     (home-page "https://github.com/ALSchwalm/transient")
     (synopsis "QEMU Wrapper written in Python")
     (description