diff mbox series

[bug#48813,2/8] gnu: Add ghc-neat-interpolation.

Message ID f68356db9f9ec536da3e3748e12c8b9c773f0b00.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-neat-interpolation): New variable.
---
 gnu/packages/haskell-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f0054948f6..98093216ee 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8514,6 +8514,38 @@  with pseudo-graphical interfaces.  This package is a nice, modern binding to GNU
 ncurses.")
     (license license:gpl3)))
 
+(define-public ghc-neat-interpolation
+  (package
+    (name "ghc-neat-interpolation")
+    (version "0.3.2.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/neat-interpolation/neat-interpolation-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "10k5x47i84nycl54p61l8v1bpvi7mw663vnj8nn1qjpn03anz8z2"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-megaparsec" ,ghc-megaparsec)))
+    (native-inputs
+      `(("ghc-quickcheck" ,ghc-quickcheck)
+        ("ghc-quickcheck-instances"
+         ,ghc-quickcheck-instances)
+        ("ghc-rerebase" ,ghc-rerebase)
+        ("ghc-tasty" ,ghc-tasty)
+        ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+        ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (home-page "https://github.com/nikita-volkov/neat-interpolation")
+    (synopsis "Quasiquoter for neat and simple multiline text interpolation")
+    (description "This package provides a quasiquoter for producing Text
+values with support for a simple interpolation of input values.  It removes the
+excessive indentation from the input and accurately manages the indentation of
+all lines of the interpolated variables.")
+    (license license:expat)))
+
 (define-public ghc-network
   (package
     (name "ghc-network")