diff mbox series

[bug#48813,6/8] gnu: Add ghc-data-tree-print.

Message ID 5ef92e1aae4954fdf8180d17a434d0fca50e0eb0.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-data-tree-print): New variable.
---
 gnu/packages/haskell-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c2c6432adb..67ffdf0055 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3078,6 +3078,45 @@  It includes hashing functions for all basic Haskell98 types.")
      "This module provides set and multiset operations on ordered lists.")
     (license license:bsd-3)))
 
+(define-public ghc-data-tree-print
+  (package
+    (name "ghc-data-tree-print")
+    (version "0.1.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/data-tree-print/data-tree-print-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "00jh37anim8qsn553467gmfhajcz1c61zrgh1ypkqsll0gc29vy3"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-syb" ,ghc-syb)))
+    (arguments
+      `(#:cabal-revision
+        ("2"
+         "00qpzhm3lndhpql8aj93aj6r3x9n0gw3nx6n0q60xxrd6agyjifq")))
+    (home-page "https://github.com/lspitzner/data-tree-print")
+    (synopsis "Print Data instances as a nested tree")
+    (description "This package provides functionality similar to that of the
+@code{Show} class: Taking some arbitrary value and returning a String.
+
+@itemize
+@item
+Output is not intended to be valid haskell.
+@item
+Requires a @code{Data.Data.Data} instance instead of a @code{Text.Show} one.
+@item
+Output, if large, is often easier to parse than @code{show} output due to the
+formatting as a nested tree.
+@item
+The user can adapt the behaviour at runtime using custom layouting expressed
+via syb-style extension.
+@end itemize")
+    (license license:bsd-3)))
+
 (define-public ghc-dbus
   (package
     (name "ghc-dbus")