diff mbox series

[bug#48813,3/8] gnu: Add ghc-multistate.

Message ID 04d86d2998b9bd069e6e9974276838fbdcafac0b.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-multistate): New variable.
---
 gnu/packages/haskell-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 98093216ee..405fe63a74 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8384,6 +8384,37 @@  Therefore, you may have to declare @code{import Control.Monad.Except ()} at
 the top of your file to get all of the ExceptT instances in scope.")
     (license license:bsd-3)))
 
+(define-public ghc-multistate
+  (package
+    (name "ghc-multistate")
+    (version "0.8.0.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/multistate/multistate-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "0hypksjacpjgpkgvjn76fd5rgdz7hi6ri36ihdy0bdhpi83jnhn5"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-tagged" ,ghc-tagged)
+        ("ghc-transformers-base" ,ghc-transformers-base)
+        ("ghc-monad-control" ,ghc-monad-control)))
+    (native-inputs `(("ghc-hspec" ,ghc-hspec)))
+    (home-page "https://github.com/lspitzner/multistate")
+    (synopsis "Similar to mtl's ReaderT/WriterT/StateT, but more than one
+contained value/type.")
+    (description "When using multiple Read/Write/State transformers in the
+same monad stack, it becomes necessary to lift the operations in order to
+affect a specific transformer.  Using heterogeneous lists (and all kinds of
+GHC extensions magic), this package provides transformers that remove that
+necessity: MultiReaderT/MultiWriterT/MultiStateT/MultiRWST can contain a
+heterogeneous list of values.")
+    (license license:bsd-3)))
+
 (define-public ghc-murmur-hash
   (package
     (name "ghc-murmur-hash")