diff mbox series

[bug#48813,5/8] gnu: Add ghc-deque.

Message ID 5a0fa813220d54ec7f6d937f1c31b3eb71e1d18b.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-deque): New variable.
---
 gnu/packages/haskell-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a77d13f822..c2c6432adb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3214,6 +3214,40 @@  providing an @code{rnf} implementation.")
 related modules split from the statistics library.")
     (license license:bsd-2)))
 
+(define-public ghc-deque
+  (package
+    (name "ghc-deque")
+    (version "0.4.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/deque/deque-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "19apwmcykprz3a91wszmc1w3qcz4x3rq79gmik514fszi9yhwsmp"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-hashable" ,ghc-hashable)
+        ("ghc-strict-list" ,ghc-strict-list)))
+    (native-inputs
+      `(("ghc-quickcheck" ,ghc-quickcheck)
+        ("ghc-quickcheck-instances"
+         ,ghc-quickcheck-instances)
+        ("ghc-rerebase" ,ghc-rerebase)
+        ("ghc-tasty" ,ghc-tasty)
+        ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+        ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (home-page
+      "https://github.com/nikita-volkov/deque")
+    (synopsis "Double-ended queues")
+    (description
+      "This package provides strict and lazy implementations of Double-Ended
+Queue (aka Dequeue or Deque) based on head-tail linked list.")
+    (license license:expat)))
+
 (define-public ghc-descriptive
   (package
     (name "ghc-descriptive")