diff mbox series

[bug#48813,4/8] gnu: Add ghc-monad-memo.

Message ID 1875aef1c39a0771c245148afdb9a6dec99f32fa.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-monad-memo): New variable.
---
 gnu/packages/haskell-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 405fe63a74..a77d13f822 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8158,6 +8158,40 @@  code locations of messages.")
 operators for looping.")
     (license license:public-domain)))
 
+(define-public ghc-monad-memo
+  (package
+    (name "ghc-monad-memo")
+    (version "0.5.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/monad-memo/monad-memo-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "1zsvp0g2kzjf5zkv1js65jfc1p3yrkr95csp2ljpqx857qy4lnn6"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-vector" ,ghc-vector)
+        ("ghc-primitive" ,ghc-primitive)
+        ("ghc-transformers-compat"
+         ,ghc-transformers-compat)))
+    (native-inputs
+      `(("ghc-random" ,ghc-random)
+        ("ghc-quickcheck" ,ghc-quickcheck)
+        ("ghc-test-framework-quickcheck2"
+         ,ghc-test-framework-quickcheck2)
+        ("ghc-test-framework" ,ghc-test-framework)))
+    (home-page
+      "https://github.com/EduardSergeev/monad-memo")
+    (synopsis "Memoization monad transformer")
+    (description "This package provides a memoization monad transformer
+supporting most of the standard monad transformers and a range of memoization
+cache types: from default pure maps to extremely fast mutable vectors.")
+    (license license:bsd-3)))
+
 (define-public ghc-monad-par
   (package
     (name "ghc-monad-par")