diff mbox series

[bug#48813,7/8] gnu: Add ghc-czipwith.

Message ID 34abb29662774a61239f01a7ae4804c3042e5eb0.1622735640.git.public@yoctocell.xyz
State New
Headers show
Series Add ghc-brittany and dependencies | expand

Commit Message

Xinglu Chen June 3, 2021, 3:58 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-czipwith): New variable.
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 67ffdf0055..446e60477b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2829,6 +2829,31 @@  Values (CSV) Files}.  This format is used, among many other things, as a
 lingua franca for spreadsheets, and for certain web services.")
     (license license:expat)))
 
+(define-public ghc-czipwith
+  (package
+    (name "ghc-czipwith")
+    (version "1.0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/czipwith/czipwith-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "17zf2blgjp47dahjcprkpymg9kb1ll6386pkr109gjr78f261gs1"))))
+    (build-system haskell-build-system)
+    (home-page
+      "https://github.com/lspitzner/czipwith/")
+    (synopsis "CZipWith class and deriving via TH")
+    (description "This package provides a typeclass similar to
+@code{Data.Distributive}, but for data parameterised with a type constructor.
+The name comes from the resemblance of its method to the regular
+@code{zipWith} function.  The abstraction is useful for example for program
+config handling.")
+    (license license:bsd-3)))
+
 (define-public ghc-data-accessor
   (package
     (name "ghc-data-accessor")