diff mbox series

[bug#64250,02/15] gnu: Add r-smoof.

Message ID f59fc6beb800648543047989b16068357edc1f74.1687527674.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** R package (scriabin) *** | expand

Commit Message

nafkhamdc June 23, 2023, 1:48 p.m. UTC
* gnu/packages/cran.scm (r-smoof): New variable.
---
 gnu/packages/cran.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d9a1914eb0..3eec62f9c2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8159,6 +8159,34 @@  (define-public r-sm
 and density estimation")
     (license license:gpl2+)))
 
+(define-public r-smoof
+  (package
+    (name "r-smoof")
+    (version "1.6.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "smoof" version))
+              (sha256
+               (base32
+                "1cazhnd0m5jjzixaqgqh2h3rsa2sw3k8slj5cmgm8v47aaqn91mg"))))
+    (properties `((upstream-name . "smoof")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbmisc
+                             r-checkmate
+                             r-ggplot2
+                             r-paramhelpers
+                             r-rcpp
+                             r-rcpparmadillo))
+    (home-page "https://jakobbossek.github.io/smoof/")
+    (synopsis "Single and multi-objective optimization test functions")
+    (description
+     "This tool generates high number of both single- and multi-objective test functions.
+These functions are frequently used for the benchmarking of
+(numerical) optimization algorithms.  Moreover, it offers a
+set of convenient functions to generate, plot and work with
+objective functions.")
+    (license license:bsd-2)))
+
 (define-public r-smurf
   (package
     (name "r-smurf")