diff mbox series

[bug#64250,11/15] gnu: Add r-cellid.

Message ID 136afa3705c111fa1e341c41b9ef84edf22a1fcf.1687527675.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** R package (scriabin) *** | expand

Commit Message

nafkhamdc June 23, 2023, 1:48 p.m. UTC
* gnu/packages/bioconductor.scm (r-cellid): New variable.
---
 gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 00701c4463..78cab7171b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1436,6 +1436,50 @@  (define-public r-celldex
 single-cell data or deconvolution of bulk RNA-seq.")
     (license license:gpl3)))
 
+(define-public r-cellid
+  (package
+    (name "r-cellid")
+    (version "1.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "CelliD" version))
+              (sha256
+               (base32
+                "0vigvqjrlqbi5kviaj8qvyq3v8afgbc5pjrz7zmx2ckf4hdp0g03"))))
+    (properties `((upstream-name . "CelliD")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-data-table
+                             r-biocparallel
+                             r-fastmatch
+							 r-fgsea
+                             r-ggplot2
+                             r-glue
+                             r-irlba
+                             r-matrix
+                             r-matrixstats
+                             r-pbapply
+                             r-rcpp
+                             r-rcpparmadillo
+                             r-reticulate
+                             r-rtsne
+                             r-seurat
+                             r-stringr
+                             r-tictoc
+							 r-singlecellexperiment
+                             r-summarizedexperiment
+                             r-umap))
+    (native-inputs (list r-knitr r-scater))
+    (home-page "https://bioconductor.org/packages/CelliD")
+    (synopsis
+     "Single cell gene signature extraction using multiple correspondence analysis")
+    (description
+     "CelliD is a clustering-free method for extracting per-cell gene signatures from scRNA-seq.
+CelliD allows unbiased cell identity recognition across different donors,
+tissues-of-origin, model organisms and single-cell omics protocols.  The
+package can also be used to explore functional pathways enrichment in
+single cell data.")
+    (license license:gpl3)))
+
 (define-public r-champdata
   (package
     (name "r-champdata")