diff mbox series

[bug#64250,10/15] gnu: Add r-dunn-test.

Message ID e92f0ae53216d1a154324b98da86719e8291ab5c.1687527675.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** R package (scriabin) *** | expand

Commit Message

nafkhamdc June 23, 2023, 1:48 p.m. UTC
* gnu/packages/cran.scm (r-dunn-test): New variable.
---
 gnu/packages/cran.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb09a8d774..2873c3ce10 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27314,6 +27314,31 @@  (define-public r-dummies
 classes into dummy/indicator variables.")
     (license license:gpl2+)))
 
+(define-public r-dunn-test
+  (package
+    (name "r-dunn-test")
+    (version "1.3.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "dunn.test" version))
+              (sha256
+               (base32
+                "0lqwvyl3pyygfc73nf81gzw3zl3w43r7ki0yw2dgrzhkpb2iji4a"))))
+    (properties `((upstream-name . "dunn.test")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=dunn.test")
+    (synopsis "Dunn's test of multiple comparisons using rank sums")
+    (description
+     "Dunn's test computes stochastic dominance & reports pairwise comparisons.
+This is done following a Kruskal-Wallis test (Kruskal and Wallis, 1952).
+It employs Dunn's z-test-statistic approximations for rank statistics,
+conducting k(k-1)/2 comparisons.  The null hypothesis assumes that the
+probability of a randomly selected value from the first group being
+larger than one from the second group is one half, similar to the
+Wilcoxon-Mann-Whitney test.  Dunn's test serves as a test for median
+difference and takes into account tied ranks.")
+    (license license:gpl2)))
+
 (define-public r-acrm
   (package
     (name "r-acrm")