diff mbox series

[bug#64250,03/15] gnu: Add r-parallelmap.

Message ID c3880cce7d7ad82832c46c650ef8d7027be4263d.1687527674.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** R package (scriabin) *** | expand

Commit Message

nafkhamdc June 23, 2023, 1:48 p.m. UTC
* gnu/packages/cran.scm (r-parallelmap): New variable.
---
 gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3eec62f9c2..7deebbe72f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2431,6 +2431,30 @@  (define-public r-paramhelpers
 object (archive) to log function evaluations is also provided.")
     (license license:bsd-2)))
 
+(define-public r-parallelmap
+  (package
+    (name "r-parallelmap")
+    (version "1.5.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "parallelMap" version))
+              (sha256
+               (base32
+                "1qg7zpz5sd9jp8wzjqahkhipwj1jn192llwg06q4gv9mlcsac261"))))
+    (properties `((upstream-name . "parallelMap")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbmisc r-checkmate))
+    (home-page "https://parallelmap.mlr-org.com")
+    (synopsis "Unified interface to parallelization back-ends")
+    (description
+     "Unified parallelization framework for multiple back-end.
+This package is designed for internal package and interactive usage.
+The main operation is parallel mapping over lists.  Supports local',
+multicore', mpi and BatchJobs mode.  Allows tagging of the parallel
+operation with a level name that can be later selected by the user to
+switch on parallel execution for exactly this operation.")
+    (license license:bsd-2)))
+
 (define-public r-pheatmap
   (package
     (name "r-pheatmap")