diff mbox series

[bug#64250,13/15] gnu: Add r-nichenetr.

Message ID a4bee2ae7f4b458aab94cde210c3da1521bdfa2c.1687527675.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series *** R package (scriabin) *** | expand

Commit Message

nafkhamdc June 23, 2023, 1:48 p.m. UTC
* gnu/packages/bioinformatics.scm (r-nichenetr): New variable.
---
 gnu/packages/bioinformatics.scm | 57 +++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 87e7c33b90..9de0470f7e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14800,6 +14800,63 @@  (define-public r-liana
 interaction inference from scRNA-seq data.")
       (license license:gpl3))))
 
+(define-public r-nichenetr
+  (let ((commit "cc3bcedfd6271df2e8ca85c8b771f7faa914cd3d")
+        (revision "1"))
+    (package
+      (name "r-nichenetr")
+      (version (git-version "1.1.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/saeyslab/nichenetr")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0jxkrk7cpwx0lbbgjrd885jxahdgk9ysfqp2drq22g486k6p2s9y"))))
+      (properties `((upstream-name . "nichenetr")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-caret
+                               r-catools
+                               r-circlize
+                               r-complexheatmap
+                               r-cowplot
+                               r-data-table
+                               r-diagrammer
+                               r-dicekriging
+                               r-dplyr
+                               r-e1071
+                               r-emoa
+                               r-fdrtool
+                               r-ggplot2
+                               r-ggpubr
+                               r-hmisc
+                               r-igraph
+                               r-limma
+                               r-magrittr
+                               r-matrix
+                               r-mlrmbo
+                               r-parallelmap
+                               r-purrr
+                               r-randomforest
+                               r-readr
+                               r-rocr
+                               r-seurat
+                               r-tibble
+                               r-tidyr))
+      (native-inputs (list r-knitr))
+	        (home-page "https://github.com/saeyslab/nichenetr")
+      (synopsis "The R implementation of the NicheNet method")
+      (description
+       "The goal of NicheNet is to study intercellular communication from a computational perspective.
+NicheNet uses human or mouse gene expression data of interacting cells
+as input and combines this with a prior model that integrates existing
+knowledge on ligand-to-target signaling paths.  This allows to predict
+ligand-receptor interactions that might drive gene expression changes
+in cells of interest.")
+      (license license:gpl3))))
+
 (define-public r-circus
   (package
     (name "r-circus")