diff mbox series

[bug#68312,064/156] gnu: Add rust-inlinable-string-0.1.

Message ID f56097b9c2209698d9beb6184dcf40fe5fcbf1c2.1704675825.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:52 a.m. UTC
* gnu/packages/crates-io.scm (rust-inlinable-string-0.1): New variable.

Change-Id: I123f060dcaf81329f503bed8908873fbfa8a667e
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 19cfed246ef..efad46c1d03 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33427,6 +33427,32 @@  (define-public rust-impl-trait-for-tuples-0.2
 a trait for tuples.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-inlinable-string-0.1
+  (package
+    (name "rust-inlinable-string")
+    (version "0.1.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "inlinable_string" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ysjci8yfvxgf51z0ny2nnwhxrclhmb3vbngin8v4bznhr3ybyn8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/fitzgen/inlinable_string")
+    (synopsis
+     "The `inlinable_string` crate provides the `InlinableString` type -- an owned, grow-able UTF-8 string that stores small strings inline and avoids heap-allocation -- and the `StringExt` trait which abstracts string operations over both `std::string::String` and `InlinableString` (or even your own custom string type).")
+    (description
+     "The `inlinable_string` crate provides the `@code{InlinableString`} type -- an
+owned, grow-able UTF-8 string that stores small strings inline and avoids
+heap-allocation -- and the `@code{StringExt`} trait which abstracts string
+operations over both `std::string::String` and `@code{InlinableString`} (or even
+your own custom string type).")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-include-dir-0.7
   (package
     (name "rust-include-dir")