diff mbox series

[bug#68312,003/156] gnu: Add rust-rocket-codegen-0.5.

Message ID 2a9efb049a1f2f88d2cf282b50358e26b8481bc9.1704675820.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:51 a.m. UTC
* gnu/packages/crates-web.scm (rust-rocket-codegen-0.5): New variable.

Change-Id: Ie443c05a6956f010d933294e0968ed1bf179e85b
---
 gnu/packages/crates-web.scm | 34 ++++++++++++++++++++++++++++------
 1 file changed, 28 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 25b17495ba4..059ce96248c 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2399,16 +2399,39 @@  (define-public rust-rocket-0.4
         ("rust-version-check" ,rust-version-check-0.9)
         ("rust-yansi" ,rust-yansi-0.5)
         ("rust-yansi" ,rust-yansi-0.5))))))
+
+(define-public rust-rocket-codegen-0.5
+  (package
+    (name "rust-rocket-codegen")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rocket_codegen" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0k6hdf9s9y73kzj89qs688gnfjj1sl4imp6pdjz22pzpmdk808x2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-devise" ,rust-devise-0.4)
+                       ("rust-glob" ,rust-glob-0.3)
+                       ("rust-indexmap" ,rust-indexmap-2)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-rocket-http" ,rust-rocket-http-0.5)
+                       ("rust-syn" ,rust-syn-2)
+                       ("rust-unicode-xid" ,rust-unicode-xid-0.2)
+                       ("rust-version-check" ,rust-version-check-0.9))))
     (home-page "https://rocket.rs")
-    (synopsis
-     "Web framework with focus on ease-of-use, expressibility, and speed")
+    (synopsis "Procedural macros for the Rocket web framework")
     (description
-     "Rocket is a web framework with a focus on ease-of-use, expressibility,
-and speed.")
+     "This package provides procedural macros for the Rocket web framework.")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-rocket-codegen-0.4
   (package
+    (inherit rust-rocket-codegen-0.5)
     (name "rust-rocket-codegen")
     (version "0.4.7")
     (source
@@ -2418,7 +2441,6 @@  (define-public rust-rocket-codegen-0.4
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "18s2dll8c4sd26s8cfr6cizj5z55xwnk6r6x7b2wvcf8n9ajrb6f"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -2428,7 +2450,7 @@  (define-public rust-rocket-codegen-0.4
         ("rust-quote" ,rust-quote-0.6)
         ("rust-rocket-http" ,rust-rocket-http-0.4)
         ("rust-version-check" ,rust-version-check-0.9)
-        ("rust-yansi" ,rust-yansi-0.5))))
+        ("rust-yansi" ,rust-yansi-0.5))))))
     (home-page "https://rocket.rs")
     (synopsis "Procedural macros for the Rocket web framework")
     (description