diff mbox series

[bug#68312,122/156] gnu: Add rust-sqlx-macros-core-0.7.

Message ID 6f497c4df793beb78caf3f8a057ca51cef138257.1704675830.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:53 a.m. UTC
* gnu/packages/crates-io.scm (rust-sqlx-macros-core-0.7): New variable.

Change-Id: Iacb7473e43339db73e0c09c36d977600728c4210
---
 gnu/packages/crates-io.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a10781f38d7..e323ca7515e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -70542,6 +70542,48 @@  (define-public rust-sqlx-0.7
 checked queries without a DSL. Supports @code{PostgreSQL}, @code{MySQL}, and
 SQLite.")
     (license (list license:expat license:asl2.0))))
+
+(define-public rust-sqlx-macros-core-0.7
+  (package
+    (name "rust-sqlx-macros-core")
+    (version "0.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sqlx-macros-core" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0h88wahkxa6nam536lhwr1y0yxlr6la8b1x0hs0n88v790clbgfh"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-async-std" ,rust-async-std-1)
+                       ("rust-atomic-write-file" ,rust-atomic-write-file-0.1)
+                       ("rust-dotenvy" ,rust-dotenvy-0.15)
+                       ("rust-either" ,rust-either-1)
+                       ("rust-heck" ,rust-heck-0.4)
+                       ("rust-hex" ,rust-hex-0.4)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-sha2" ,rust-sha2-0.10)
+                       ("rust-sqlx-core" ,rust-sqlx-core-0.7)
+                       ("rust-sqlx-mysql" ,rust-sqlx-mysql-0.7)
+                       ("rust-sqlx-postgres" ,rust-sqlx-postgres-0.7)
+                       ("rust-sqlx-sqlite" ,rust-sqlx-sqlite-0.7)
+                       ("rust-syn" ,rust-syn-1)
+                       ("rust-tempfile" ,rust-tempfile-3)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-url" ,rust-url-2))))
+    (home-page "https://github.com/launchbadge/sqlx")
+    (synopsis
+     "Macro support core for SQLx, the Rust SQL toolkit. Not intended to be used directly.")
+    (description
+     "Macro support core for SQLx, the Rust SQL toolkit.  Not intended to be used
+directly.")
+    (license (list license:expat license:asl2.0))))
 (define-public rust-sqlite-0.30
   (package
     (name "rust-sqlite")