diff mbox series

[bug#68312,133/156] gnu: Add rust-sync-wrapper-0.1.

Message ID 52054ccc54c69d225ec863600423f775d48dea17.1704675831.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:53 a.m. UTC
* gnu/packages/crates-io.scm (rust-sync-wrapper-0.1): New variable.

Change-Id: Ice2cec929e61e5a451fec23ecbb73488ad3a2276
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 755a53b320d..beea3d63378 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -73994,6 +73994,29 @@  (define-public rust-syn-derive-0.1
     (description "Derive macros for `syn::Parse` and `quote::@code{ToTokens`}")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-sync-wrapper-0.1
+  (package
+    (name "rust-sync-wrapper")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "sync_wrapper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q01lyj0gr9a93n10nxsn8lwbzq97jqd6b768x17c8f7v7gccir0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-futures-core" ,rust-futures-core-0.3))))
+    (home-page "https://docs.rs/sync_wrapper")
+    (synopsis
+     "A tool for enlisting the compiler’s help in proving the absence of concurrency")
+    (description
+     "This package provides a tool for enlisting the compiler’s help in proving the
+absence of concurrency")
+    (license license:asl2.0)))
+
 (define-public rust-synom-0.11
   (package
     (name "rust-synom")