diff mbox series

[bug#68312,025/156] gnu: Add rust-borsh-derive-1.

Message ID 66993a68c33e952769ad93084f46b4eacae7cd4d.1704675822.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:52 a.m. UTC
* gnu/packages/crates-io.scm (rust-borsh-derive-1): New variable.
(rust-borsh-derive-0.10): Inherit from rust-borsh-derive-1.

Change-Id: I3b9c5a27fe31d6269c0792d090f022c904e77e2f
---
 gnu/packages/crates-io.scm | 38 ++++++++++++++++++++++++++------------
 1 file changed, 26 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 424aa46f49c..4fc06fcc552 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8183,16 +8183,35 @@  (define-public rust-borsh-0.10
         ("rust-hashbrown" ,rust-hashbrown-0.13))
        #:cargo-development-inputs
        (("rust-bytes" ,rust-bytes-1))))))
+
+(define-public rust-borsh-derive-1
+  (package
+    (name "rust-borsh-derive")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "borsh-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1q0h8y7xpilasaqc3s7drjh3qzxk7k83wc5ns9x7gpf4kiq1hjdz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-proc-macro-crate" ,rust-proc-macro-crate-2)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2)
+                       ("rust-syn-derive" ,rust-syn-derive-0.1))))
     (home-page "https://borsh.io")
-    (synopsis "Borsch is the binary object representation serializer for hashing")
-    (description "This crate implements @code{borsh}, the binary object
-representation serializer for hasing.  It is meant to be used in
-security-critical projects as it prioritizes consistency, safety, speed, and
-comes with a strict specification.")
-    (license (list license:expat license:asl2.0))))
+    (synopsis "Derive proc-macros for @code{borsh}")
+    (description "This crate implements derive proc-macros for @code{borsh}.")
+    (license license:asl2.0)))
 
 (define-public rust-borsh-derive-0.10
   (package
+    (inherit rust-borsh-derive-1)
     (name "rust-borsh-derive")
     (version "0.10.3")
     (source
@@ -8202,18 +8221,13 @@  (define-public rust-borsh-derive-0.10
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1xslbx3qj531aq8ny1bkr45ibjmpsx0szsfc57rm33akj4v62m07"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-borsh-derive-internal" ,rust-borsh-derive-internal-0.10)
         ("rust-borsh-schema-derive-internal" ,rust-borsh-schema-derive-internal-0.10)
         ("rust-proc-macro-crate" ,rust-proc-macro-crate-0.1)
         ("rust-proc-macro2" ,rust-proc-macro2-1)
-        ("rust-syn" ,rust-syn-1))))
-    (home-page "https://borsh.io")
-    (synopsis "Derive proc-macros for @code{borsh}")
-    (description "This crate implements derive proc-macros for @code{borsh}.")
-    (license license:asl2.0)))
+        ("rust-syn" ,rust-syn-1))))))
 
 (define-public rust-borsh-derive-internal-0.10
   (package