diff mbox series

[bug#68312,096/156] gnu: Add rust-poly1305-0.8.

Message ID 92817f78b56a7514416a8bea7fc1a9f182a33528.1704675828.git.w@wmeyer.eu
State New
Headers show
Series Add atuin (WIP). | expand

Commit Message

Wilko Meyer Jan. 8, 2024, 1:53 a.m. UTC
* gnu/packages/crates-io.scm (rust-poly1305-0.8): New variable.
(rust-poly1305-0.7): Inherit from rust-poly1305-0.8.

Change-Id: I853879812db8636e3a5ef8743ac5215f97156685
---
 gnu/packages/crates-io.scm | 35 +++++++++++++++++++++++++++--------
 1 file changed, 27 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c56313a2a8d..307edaac393 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52737,8 +52737,34 @@  (define-public rust-pollster-macro-0.1
     (description "Proc-macro crate for pollster.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-poly1305-0.8
+  (package
+    (name "rust-poly1305")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "poly1305" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1grs77skh7d8vi61ji44i8gpzs3r9x7vay50i6cg8baxfa8bsnc1"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-cpufeatures" ,rust-cpufeatures-0.2)
+                       ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+                       ("rust-universal-hash" ,rust-universal-hash-0.5)
+                       ("rust-zeroize" ,rust-zeroize-1))))
+    (home-page "https://github.com/RustCrypto/universal-hashes")
+    (synopsis "Poly1305 universal hash")
+    (description
+     "Poly1305 is a universal hash function which, when combined with
+a cipher, can be used as a Message Authentication Code (MAC).")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-poly1305-0.7
   (package
+    (inherit rust-poly1305-0.8)
     (name "rust-poly1305")
     (version "0.7.2")
     (source
@@ -52752,7 +52778,6 @@  (define-public rust-poly1305-0.7
        (snippet
         '(begin (substitute* "Cargo.toml"
                   (("version = \">=1, <1\\.4\"") "version = \"^1\""))))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-cpufeatures" ,rust-cpufeatures-0.2)
@@ -52760,13 +52785,7 @@  (define-public rust-poly1305-0.7
         ("rust-universal-hash" ,rust-universal-hash-0.4)
         ("rust-zeroize" ,rust-zeroize-1))
        #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/universal-hashes")
-    (synopsis "Poly1305 universal hash")
-    (description
-     "Poly1305 is a universal hash function which, when combined with
-a cipher, can be used as a Message Authentication Code (MAC).")
-    (license (list license:asl2.0 license:expat))))
+       (("rust-hex-literal" ,rust-hex-literal-0.3))))))
 
 (define-public rust-polyval-0.6
   (package