diff mbox series

[bug#66579,v2,01/15] gnu: Add rust-hyper-proxy

Message ID e8e910ed96319a235ec29f24d2f7fbb5530eced9.1697832330.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-hyper-proxy): New variable.
---
 gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 80fb92ec82..8dc31b9cd6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30717,6 +30717,46 @@  (define-public rust-humantime-1
         ("rust-rand" ,rust-rand-0.4)
         ("rust-time" ,rust-time-0.1))))))
 
+(define-public rust-hyper-proxy-0.9
+  (package
+    (name "rust-hyper-proxy")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "hyper-proxy" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1k3mpq6d4rhz58dam1757sav14j32n39q8x37wjgpz943f4mm0fa"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs `(("rust-bytes" ,rust-bytes-1)
+                            ("rust-futures" ,rust-futures-0.3)
+                            ("rust-headers" ,rust-headers-0.3)
+                            ("rust-http" ,rust-http-0.2)
+                            ("rust-hyper" ,rust-hyper-0.14)
+                            ("rust-tokio" ,rust-tokio-1)
+                            ("rust-tower-service" ,rust-tower-service-0.3)
+                            ("rust-hyper-rustls" ,rust-hyper-rustls-0.22)
+                            ("rust-hyper-tls" ,rust-hyper-tls-0.5)
+                            ("rust-native-tls" ,rust-native-tls-0.2)
+                            ("rust-openssl" ,rust-openssl-0.10)
+                            ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.5)
+                            ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+                            ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+                            ("rust-tokio-rustls" ,rust-tokio-rustls-0.22)
+                            ("rust-webpki" ,rust-webpki-0.21)
+                            ("rust-webpki-roots" ,rust-webpki-roots-0.21))
+           #:cargo-development-inputs `(("rust-hyper" ,rust-hyper-0.14)
+                                        ("rust-tokio" ,rust-tokio-1))))
+    (native-inputs (list pkg-config))
+    (inputs (list openssl))
+    (home-page "https://github.com/tafia/hyper-proxy")
+    (synopsis "Proxy connector for Hyper-based applications")
+    (description "Proxy connector for the Hyper HTTP library.")
+    (license license:expat)))
+
 (define-public rust-hyper-0.14
   (package
     (name "rust-hyper")