diff mbox series

[bug#66579,v2,04/15] gnu: Add rust-librespot-protocol.

Message ID 989cda6ab734e3c7af7dd1d3fc14f4480ae500d5.1697832330.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-librespot-protocol): New variable.
---
 gnu/packages/crates-io.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1e5e99b719..154e608724 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35587,6 +35587,30 @@  (define-public rust-libradicl-0.4
 single-cell and single-nucleus sequencing data.")
     (license license:bsd-3)))
 
+(define-public rust-librespot-protocol-0.4
+  (package
+    (name "rust-librespot-protocol")
+    (version "0.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "librespot-protocol" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "17xkvhlxfkjh1z79pvq22nrxi99hcxnzafg0pdkymh3a3733lvax"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs `(("rust-protobuf" ,rust-protobuf-2)
+                            ("rust-glob" ,rust-glob-0.3)
+                            ("rust-protobuf-codegen-pure" ,rust-protobuf-codegen-pure-2))))
+    (home-page "https://github.com/librespot-org/librespot")
+    (synopsis "The protobuf logic for communicating with Spotify servers")
+    (description "Part of Librespot, an open source, Spotify client library.
+This package contains the protobuf logic.")
+    (license license:expat)))
+
+
 (define-public rust-libsqlite3-sys-0.26
   (package
     (name "rust-libsqlite3-sys")