diff mbox series

[bug#66579,v2,11/15] gnu: Add rust-librespot-audio.

Message ID d35f43ac0254952101716a6ef0f62e50db0e633a.1697832330.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-librespot-audio): New variable.
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f1e21aa76f..0d91643cef 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35615,6 +35615,35 @@  (define-public rust-libradicl-0.4
 single-cell and single-nucleus sequencing data.")
     (license license:bsd-3)))
 
+(define-public rust-librespot-audio-0.4
+  (package
+    (name "rust-librespot-audio")
+    (version "0.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "librespot-audio" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "178djijj7fkg5ca5rhk10rvy9gs797gikvackh5qxsp1al9s6xn1"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs `(("rust-aes-ctr" ,rust-aes-ctr-0.6)
+                            ("rust-byteorder" ,rust-byteorder-1)
+                            ("rust-bytes" ,rust-bytes-1)
+                            ("rust-futures-util" ,rust-futures-util-0.3)
+                            ("rust-librespot-core" ,rust-librespot-core-0.4)
+                            ("rust-log" ,rust-log-0.4)
+                            ("rust-tempfile" ,rust-tempfile-3)
+                            ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/librespot-org/librespot")
+    (synopsis "The audio fetching logic for Librespot")
+    (description
+     "Part of Librespot, an open source client library
+for Spotify.  This package contains the audio fetching logic.")
+    (license license:expat)))
+
 (define-public rust-librespot-core-0.4
   (package
     (name "rust-librespot-core")