diff mbox series

[bug#66579,v2,10/15] gnu: Add rust-aes-ctr.

Message ID 2c462d3933225e3625839d1523fbb83f6acec255.1697832330.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:27 p.m. UTC
* gnu/packages/crates-io.scm (rust-aes-ctr): New variable.
---
 gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ffc7891ee8..f1e21aa76f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2106,6 +2106,34 @@  (define-public rust-aes-0.3
         ("rust-aesni" ,rust-aesni-0.6)
         ("rust-block-cipher-trait" ,rust-block-cipher-trait-0.6))))))
 
+(define-public rust-aes-ctr-0.6
+  (package
+    (name "rust-aes-ctr")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aes-ctr" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0qspjxzrclnb83501595y01dhc0km1ssrbjnwlxhcrsdwp6w6abp"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list
+      #:skip-build? #f
+      #:cargo-inputs `(("rust-aesni" ,rust-aesni-0.10)
+                       ("rust-aes-soft" ,rust-aes-soft-0.6)
+                       ("rust-cipher" ,rust-cipher-0.2)
+                       ("rust-ctr" ,rust-ctr-0.6))
+      #:cargo-development-inputs `(("rust-cipher" ,rust-cipher-0.2))))
+    (home-page "https://github.com/RustCrypto/block-ciphers/tree/master/aes")
+    (synopsis "Pure Rust implementation of AES")
+    (description
+     "A pure Rust implementation of the Advanced Encryption
+Standard (AES).  Use the AES crate if possible, as the aes-ctr has been
+into it.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-aes-gcm-0.10
   (package
     (name "rust-aes-gcm")