diff mbox series

[bug#66579,v2,03/15] gnu: rust-protobuf-codegen & rust-protobuf-codegen-pure: Update to 2.28.0.

Message ID 496692cdea6387b0d8c4cf3c9a7bf3ea9a614acd.1697832330.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:27 p.m. UTC
* gnu/packages/crates-io.scm: (rust-protobuf-codegen): Update to 2.28.0.
* gnu/packages/crates-io.scm: (rust-protobuf-codegen-pure): Update to 2.28.0.
---
 gnu/packages/crates-io.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 486c53ba85..1e5e99b719 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -50088,7 +50088,7 @@  (define-public rust-protobuf-2
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "11bl8hf522s9mbkckivnn9n8s3ss4g41w6jmfdsswmr5adqd71lf"))))
+                 "154dfzjvxlpx37ha3cmp7fkhcsnyzbnfv7aisvz34x23k2gdjv8h"))))
     (build-system cargo-build-system)
     (arguments
      `(#:tests? #f          ; missing files in the release tarball.
@@ -50107,14 +50107,14 @@  (define-public rust-protobuf-2
 (define-public rust-protobuf-codegen-2
   (package
     (name "rust-protobuf-codegen")
-    (version "2.14.0")
+    (version "2.28.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "protobuf-codegen" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "031bx325lsgcx7wc76vc2cqph6q0b34jgc8nz0g2rkwcfnx3n4fy"))))
+                 "1mhpl2cs1d2sqddf097ala180il61g9axpqnzky5bxswnypn0d03"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-protobuf" ,rust-protobuf-2))))
@@ -50131,17 +50131,18 @@  (define-public rust-protobuf-codegen-2
 (define-public rust-protobuf-codegen-pure-2
   (package
     (name "rust-protobuf-codegen-pure")
-    (version "2.14.0")
+    (version "2.28.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "protobuf-codegen-pure" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0h34gfqlb7bqmgqv1mfgy5wk35z5r2h5ki3p3pdcmw1vqzmly6id"))))
+                 "0rfqvpbbqh4pa406nda54jdl0sgagdgp274mmbpd7g4lzjcr78lm"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
+     `(#:tests? #f
+       #:cargo-inputs
        (("rust-protobuf" ,rust-protobuf-2)
         ("rust-protobuf-codegen" ,rust-protobuf-codegen-2))))
     (home-page "https://github.com/stepancheg/rust-protobuf/")