diff mbox series

[bug#66579,v2,15/15] gnu: Add rust-librespot-metadata.

Message ID 9c67f22ce24294241e78226e4e314e5fa1f8b0d6.1697832331.git.steve@futurile.net
State New
Headers show
Series Series to add rust-librespot-core, audio and discovery | expand

Commit Message

Steve George Oct. 20, 2023, 8:28 p.m. UTC
* gnu/packages/crates-io.scm (rust-librespot-metadata): New variable.
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7729e1a569..04e845a0db 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35787,6 +35787,32 @@  (define-public rust-librespot-discovery-0.4
 Spotify.  This package contains the discovery logic.")
     (license license:expat)))
 
+(define-public rust-librespot-metadata-0.4
+  (package
+    (name "rust-librespot-metadata")
+    (version "0.4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "librespot-metadata" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "07626b84cghd3jabdvyqhn1v0lax9p1hhz6ldw2r4l6brcgkd03b"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs `(("rust-async-trait" ,rust-async-trait-0.1)
+                            ("rust-byteorder" ,rust-byteorder-1)
+                            ("rust-librespot-core" ,rust-librespot-core-0.4)
+                            ("rust-librespot-protocol" ,rust-librespot-protocol-0.4)
+                            ("rust-log" ,rust-log-0.4)
+                            ("rust-protobuf" ,rust-protobuf-2))))
+    (home-page "https://github.com/librespot-org/librespot")
+    (synopsis "The metadata elements of Librespot")
+    (description "Part of Librespot, an open source client library for
+Spotify.  This package contains the metadata logic.")
+    (license license:expat)))
+
 (define-public rust-librespot-protocol-0.4
   (package
     (name "rust-librespot-protocol")