diff mbox series

[bug#63806,02/18] gnu: Add python-rad.

Message ID e35fbbc825e23345831eafe37ee2ece60ad43477.1685475210.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnu/packages/astronomy.scm (python-rad): New variable.
---
 gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 5429cceeae..359704f8dd 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3082,6 +3082,36 @@  (define-public python-gwcs
 default) to world coordinates.")
     (license license:bsd-3)))
 
+(define-public python-rad
+  (package
+    (name "python-rad")
+    (version "0.15.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "rad" version))
+              (sha256
+               (base32
+                "0j51pkywxdaqrfz162rdsywlvx1mbb2h0gi5framvhf25i1im7mb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags #~(list "-k" "not remote_data")))
+    (native-inputs (list python-astropy
+                         python-pytest
+                         python-pytest-doctestplus
+                         python-pytest-openfiles
+                         python-semantic-version
+                         python-setuptools-scm))
+    (propagated-inputs (list python-asdf python-asdf-astropy))
+    (home-page "https://github.com/spacetelescope/rad")
+    (synopsis "Roman Attribute Dictionary")
+    (description
+     "@acronym{RAD, The Roman Attribute Dictionary} is package which defines schemas
+for the Nancy Grace Roman Space Telescope shared attributes for processing and
+archive.  These schemas are schemas for the ASDF file file format, which are used
+by ASDF to serialize and deserialize data for the Nancy Grace Roman Space
+Telescope.")
+    (license license:bsd-3)))
+
 (define-public python-astroalign
   (package
     (name "python-astroalign")