diff mbox series

[bug#63806,01/18] gnu: Add python-pysynshot.

Message ID 689752c22c5bec055b487f45d696cb6da0e647b6.1685475210.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnp/packages/astronomy.scm (python-pysynshot): New variable.
---
 gnu/packages/astronomy.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 964e72642c..5429cceeae 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2687,6 +2687,38 @@  (define-public python-pynbody
 N-Chilada and RAMSES AMR outputs.")
     (license license:gpl3+)))
 
+(define-public python-pysynphot
+  (package
+    (name "python-pysynphot")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pysynphot" version))
+              (sha256
+               (base32
+                "1rr29m63bnj47f6gvbvg3pm1296x14ad29c6qd0sdj4f4ilrzhj5"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'set-env-data-path
+                          (lambda _
+                            (setenv "PYSYN_CDBS"
+                                    (string-append #$output "/crds")))))))
+    (native-inputs (list python-pytest python-pytest-remotedata
+                         python-setuptools-scm))
+    (propagated-inputs (list python-astropy python-beautifulsoup4 python-numpy
+                             python-pytest-astropy-header python-six))
+    (home-page "https://github.com/spacetelescope/pysynphot")
+    (synopsis "Python Synthetic Photometry Utilities")
+    (description
+     "Astrolib PySynphot (hereafter referred to only as pysynphot) is an
+object-oriented replacement for STSDAS SYNPHOT synthetic photometry package in
+IRAF.  @code{pysynphot} simulates photometric data and spectra as they are observed
+with the Hubble Space Telescope (HST). Passbands for standard photometric
+systems are available, and users can incorporate their own filters, spectra, and
+data.")
+    (license license:bsd-3)))
+
 (define-public python-sep
   (package
     (inherit libsep)