diff mbox series

[bug#63806,09/18] gnu: Add python-stsynphot.

Message ID 53d84e2e9a593c5e9fd340027535ee9d37bf3213.1685475211.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnu/packages/astronomy.scm (python-stsynphot): New variable.
---
 gnu/packages/astronomy.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9373eaed40..5b673350ba 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2120,6 +2120,40 @@  (define-public python-stsci-stimage
 image processing functions: @code{xyxymatch}, @code{geomap}.")
     (license license:bsd-3)))
 
+(define-public python-stsynphot
+  (package
+    (name "python-stsynphot")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsynphot" version))
+              (sha256
+               (base32
+                "0qkdh47j84v7fzri7bmi1jcmggdqq0a8byamfm73d8mbz86v8sn4"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: Tests fails on missing file, it might need to be downloaded,
+      ;; disable them for now.  astropy.utils.exceptions.AstropyUserWarning:
+      ;; Failed to load Vega spectrum from
+      ;; /grp/redcat/trds/calspec/alpha_lyr_stis_010.fits;
+      #:tests? #f))
+    (propagated-inputs (list python-astropy
+                             python-beautifulsoup4
+                             python-matplotlib
+                             python-numpy
+                             python-scipy
+                             python-synphot))
+    (native-inputs (list python-pytest python-pytest-astropy
+                         python-pytest-astropy-header python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stsynphot_refactor")
+    (synopsis "Synthetic photometry using Astropy for HST and JWST")
+    (description
+     "This package provides a replacement for IRAF STSDAS SYNPHOT
+and ASTROLIB PYSYNPHOT, utilizing Astropy covering instrument specific portions
+of the old packages for HST.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")