diff mbox series

[bug#63806,12/18] gnu: Add python-stdatamodels.

Message ID 26fb287354512465fb2b97ee1961661e71283fa9.1685475211.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnu/packages/astronomy.scm (python-stdatamodels): New variable.
---
 gnu/packages/astronomy.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d5fb41f7c4..6f5d06f634 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2172,6 +2172,48 @@  (define-public python-stsci-stimage
 image processing functions: @code{xyxymatch}, @code{geomap}.")
     (license license:bsd-3)))
 
+(define-public python-stdatamodels
+  (package
+    (name "python-stdatamodels")
+    (version "1.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stdatamodels" version))
+              (sha256
+               (base32
+                "1lssz5mnkzgraqa9mdg1w39scsikymcp3zpmsjb146r0pqnwnpzw"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; Disable tests requiring access to CRDS servers to download ~500MiB
+      ;; of data.
+      #:test-flags #~(list "-k" "not test_crds_selectors_vs_datamodel")
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'set-home
+                     (lambda _
+                       (setenv "HOME" "/tmp"))))))
+    (propagated-inputs (list python-asdf
+                             python-asdf-astropy
+                             python-astropy
+                             python-jsonschema
+                             python-numpy
+                             python-psutil))
+    (native-inputs (list python-crds
+                         python-pytest
+                         python-pytest-doctestplus
+                         python-pytest-openfiles
+                         python-scipy
+                         python-semantic-version
+                         python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stdatamodels")
+    (synopsis
+     "Core support for DataModel classes used in calibration pipelines")
+    (description
+     "Provides DataModel, which is the base class for data models implemented in the
+@acronym{JWST, James Webb Space Telescope} and @acronym{Roman, Nancy Grace Roman
+Space Telescope} calibration software.")
+    (license license:bsd-3)))
+
 (define-public python-stsynphot
   (package
     (name "python-stsynphot")