diff mbox series

[bug#63806,06/18] gnu: Add python-stsci-stimage.

Message ID 7ec11f9deb99b333f940048959d4e8915ba94927.1685475210.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnu/packages/astronomy.scm (python-stsci-stimage): New variable.
---
 gnu/packages/astronomy.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 41e79205ba..2b0cd113e5 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2096,6 +2096,30 @@  (define-public python-stsci-imagestats
 behaviour of the IRAF's")
     (license license:bsd-3)))
 
+(define-public python-stsci-stimage
+  (package
+    (name "python-stsci-stimage")
+    (version "0.2.6")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsci.stimage" version))
+              (sha256
+               (base32
+                "0i7xby1gaiplvbqqv8a4f4cw1is8fwj89mix1z3bqrykqi3n24g0"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: Fix failing tests. There are errors to load test files.
+      #:tests? #f))
+    (propagated-inputs (list python-numpy))
+    (native-inputs (list python-codecov python-pytest python-pytest-cov
+                         python-setuptools-scm))
+    (home-page "https://stscistimage.readthedocs.io/en/latest/")
+    (synopsis "STScI image processing")
+    (description "This package provides an astronomical Python package with
+image processing functions: @code{xyxymatch}, @code{geomap}.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")