diff mbox series

[bug#63806,05/18] gnu: Add python-stsci-imagestats.

Message ID 7996467143ec4946c869c8b66826e66bc39c3089.1685475210.git.sharlatanus@gmail.com
State New
Headers show
Series : gnu: Add JWST (James Webb Space Telescope) | expand

Commit Message

Sharlatan Hellseher May 30, 2023, 7:58 p.m. UTC
* gnu/packages/astronomy.scm (python-stsci-imagestats): New variable.
---
 gnu/packages/astronomy.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e2a8796149..41e79205ba 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2073,6 +2073,29 @@  (define-public python-stsci-image
 Institute} image array manipulation functions")
     (license license:bsd-3)))
 
+(define-public python-stsci-imagestats
+  (package
+    (name "python-stsci-imagestats")
+    (version "1.6.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsci.imagestats" version))
+              (sha256
+               (base32
+                "14457izlbnks84dyza75ib3nvx2w8nhlqm9vc1zb7hbhknb5gjvw"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:tests? #f)) ;No teests
+    (propagated-inputs (list python-numpy))
+    (native-inputs (list python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stsci.imagestats")
+    (synopsis "Compute sigma-clipped statistics on data arrays")
+    (description
+     "@code{stsci.imagestats} is a package designed to compute various statistics on
+image data using sigma-clipping iterations.  It is designed to replicate core
+behaviour of the IRAF's")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")