diff mbox series

[bug#68556,gnome-team,02/25] gnu: gnome-shell-extension-hide-app-icon: Modernize style.

Message ID d934067573a97325b93840d3a9662b52110bb8cf.1705532622.git.vivien@planete-kraus.eu
State New
Headers show
Series Update the GNOME Shell extensions | expand

Commit Message

Vivien Kraus Jan. 16, 2024, 9:31 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon)
[arguments]: Convert to list of G-Expressions.

Change-Id: Ifd937163d7e7fce95c4bed1a2a856487ed225d2d
---
 gnu/packages/gnome-xyz.scm | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index f41048c55e..2488e93eb9 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -870,20 +870,19 @@  (define-public gnome-shell-extension-hide-app-icon
          (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
-       '(#:tests? #f                ; no test target
-         #:make-flags (list (string-append "EXTENSIONS_DIR="
-                                           (assoc-ref %outputs "out")
-                                           "/share/gnome-shell/extensions"))
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)      ; no configure script
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let ((out (assoc-ref outputs "out"))
-                     (pre "/share/gnome-shell/extensions/")
-                     (dir "hide-app-icon@mrapp.sourceforge.com"))
-                 (copy-recursively dir (string-append out pre dir))
-                 #t))))))
+       (list
+        #:tests? #f                ; no test target
+        #:make-flags #~(list (string-append "EXTENSIONS_DIR="
+                                            #$output
+                                            "/share/gnome-shell/extensions"))
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete 'configure)      ; no configure script
+            (replace 'install
+              (lambda _
+                (let ((pre "/share/gnome-shell/extensions/")
+                      (dir "hide-app-icon@mrapp.sourceforge.com"))
+                  (copy-recursively dir (string-append #$output pre dir))))))))
       (native-inputs
        (list `(,glib "bin") intltool))
       (propagated-inputs