diff mbox series

[bug#68556,gnome-team,20/25] gnu: gnome-shell-extension-paperwm: Update to 44.17.0.

Message ID d02e2262e616ad0ce9b594756d905fc6d22a51d8.1705532622.git.vivien@planete-kraus.eu
State New
Headers show
Series Update the GNOME Shell extensions | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 10:36 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): Update to
44.17.0.
[arguments]: Convert to list of G-Expressions.
[native-inputs]: Drop labels.

Change-Id: Ib4e42ade9f02a02a6ef5c775f78428aa0c1ead77
---
 gnu/packages/gnome-xyz.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index ad04d57ec9..091e8f89cb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -945,33 +945,33 @@  (define-public gnome-shell-extension-dash-to-panel
 (define-public gnome-shell-extension-paperwm
   (package
     (name "gnome-shell-extension-paperwm")
-    (version "36.0")
+    (version "44.17.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/paperwm/PaperWM")
-                    (commit version)))
+                    (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ssnabwxrns36c61ppspjkr9i3qifv08pf2jpwl7cjv3pvyn4kly"))
+                "1d91k9qih81wckqf6554kf8grv6q61rkk4g776g0ijpmf35ljdin"))
               (snippet
                '(begin (delete-file "schemas/gschemas.compiled")))))
     (build-system copy-build-system)
     (arguments
-     '(#:install-plan
-       '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'compile-schemas
-           (lambda _
-             (with-directory-excursion "schemas"
-               (invoke "make"))
-             #t)))))
+     (list
+      #:install-plan
+      #~'(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
+           #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                             "\\.xml$" "\\.compiled$")))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'compile-schemas
+            (lambda _
+              (with-directory-excursion "schemas"
+                (invoke "make")))))))
     (native-inputs
-     `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
+     (list `(,glib "bin"))) ; for glib-compile-schemas
     (home-page "https://github.com/paperwm/PaperWM")
     (synopsis "Tiled scrollable window management for GNOME Shell")
     (description "PaperWM is an experimental GNOME Shell extension providing