diff mbox series

[bug#68556,gnome-team,03/25] gnu: Remove gnome-shell-extension-hide-app-icon.

Message ID 711f86a2163f3ddf0e672be5117d351cce1424b2.1705532622.git.vivien@planete-kraus.eu
State New
Headers show
Series Update the GNOME Shell extensions | expand

Commit Message

Vivien Kraus Jan. 17, 2024, 4:20 p.m. UTC
This extension does not work with GNOME 44, and has not received any work.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-hide-app-icon): Remove variable.

Change-Id: I6af14b6c9e1db7176d9be6bec2b90f77e7db36c1
---
 gnu/packages/gnome-xyz.scm | 47 --------------------------------------
 1 file changed, 47 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 2488e93eb9..d96cf953c6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -851,53 +851,6 @@  (define-public gnome-shell-extension-gsconnect
 control.")
     (license license:gpl2)))
 
-(define-public gnome-shell-extension-hide-app-icon
-  (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
-        (revision "0"))
-    (package
-      (name "gnome-shell-extension-hide-app-icon")
-      (version (git-version "2.7" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url (string-append "https://github.com/michael-rapp"
-                                   "/gnome-shell-extension-hide-app-icon.git"))
-               (commit commit)))
-         (sha256
-          (base32
-           "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
-         (file-name (git-file-name name version))))
-      (build-system gnu-build-system)
-      (arguments
-       (list
-        #:tests? #f                ; no test target
-        #:make-flags #~(list (string-append "EXTENSIONS_DIR="
-                                            #$output
-                                            "/share/gnome-shell/extensions"))
-        #:phases
-        #~(modify-phases %standard-phases
-            (delete 'configure)      ; no configure script
-            (replace 'install
-              (lambda _
-                (let ((pre "/share/gnome-shell/extensions/")
-                      (dir "hide-app-icon@mrapp.sourceforge.com"))
-                  (copy-recursively dir (string-append #$output pre dir))))))))
-      (native-inputs
-       (list `(,glib "bin") intltool))
-      (propagated-inputs
-       (list glib))
-      (synopsis "Hide app icon from GNOME's panel")
-      (description "This extension hides the icon and/or title of the
-currently focused application in the top panel of the GNOME shell.")
-      (home-page
-       "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
-      (license
-        ;; README.md and LICENSE.txt disagree -- the former claims v3, the
-        ;; latter v2.  No mention of "or later" in either place or in the code.
-        (list license:gpl2
-              license:gpl3)))))
-
 (define-public gnome-shell-extension-just-perfection
   (package
     (name "gnome-shell-extension-just-perfection")