diff mbox series

[bug#68556,gnome-team,09/25] gnu: gnome-shell-extension-topicons-redux: Update style.

Message ID 89b0e5f79d6ced58f901fad0cb27f544aedc5788.1705532622.git.vivien@planete-kraus.eu
State New
Headers show
Series Update the GNOME Shell extensions | expand

Commit Message

Vivien Kraus Jan. 16, 2024, 9:50 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-topicons-redux)
[arguments]: Convert to list of G-Expressions.
<#:phases>: Do not replace 'install.
<#:make-flags>: Add INSTALL_PATH.

Change-Id: Iddccb8dd959ccd9edcefc9b76b5b2b4808e5b231
---
 gnu/packages/gnome-xyz.scm | 23 +++++++++--------------
 1 file changed, 9 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index fea25ab63f..efe040c37e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -699,20 +699,15 @@  (define-public gnome-shell-extension-topicons-redux
     (native-inputs
      (list `(,glib "bin")))
     (arguments
-     `(#:tests? #f                      ;no test defined in the project
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'build)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (invoke "make"
-                       "install"
-                       (string-append
-                        "INSTALL_PATH="
-                        out
-                        "/share/gnome-shell/extensions"))))))))
+     (list
+      #:tests? #f                      ;no test defined in the project
+      #:make-flags
+      #~(list (string-append "INSTALL_PATH=" #$output
+                             "/share/gnome-shell/extensions"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (delete 'build))))
     (home-page "https://gitlab.com/pop-planet/TopIcons-Redux")
     (synopsis "Display legacy tray icons in the GNOME Shell top panel")
     (description "Many applications, such as chat clients, downloaders, and