diff mbox series

[bug#68556,gnome-team,04/25] gnu: gnome-shell-extension-dash-to-panel: Update to 56.

Message ID 27465476b1e201a11448966a9c18dbd3b1f5efed.1705532622.git.vivien@planete-kraus.eu
State New
Headers show
Series Update the GNOME Shell extensions | expand

Commit Message

Vivien Kraus Jan. 16, 2024, 9:31 p.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-dash-to-panel): Update to
56.
[arguments]: Convert to list of G-Expressions.
[native-inputs]: Add `(,glib "bin").
[propagated-inputs]: Remove `(,glib "bin").

Change-Id: I24a83766b750feb1004bbaf2f5badc9e21f1c30e
---
 gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++--------------
 1 file changed, 16 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d96cf953c6..d4028cd913 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -905,7 +905,7 @@  (define-public gnome-shell-extension-just-perfection
 (define-public gnome-shell-extension-dash-to-panel
   (package
     (name "gnome-shell-extension-dash-to-panel")
-    (version "56")
+    (version "56") ;Compatible with GNOME 44
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -917,22 +917,24 @@  (define-public gnome-shell-extension-dash-to-panel
               (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f
-       #:make-flags (list (string-append "INSTALLBASE="
-                                         (assoc-ref %outputs "out")
-                                         "/share/gnome-shell/extensions")
-                          (string-append "VERSION="
-                                         ,(package-version
-                                           gnome-shell-extension-dash-to-panel)))
+     (list
+      #:tests? #f
+      #:make-flags #~(list (string-append "INSTALLBASE="
+                                          #$output
+                                          "/share/gnome-shell/extensions")
+                           (string-append "VERSION="
+                                          #$version))
        #:phases
-       (modify-phases %standard-phases
-         (delete 'bootstrap)
-         (delete 'configure))))
+       #~(modify-phases %standard-phases
+           (delete 'bootstrap)
+           (delete 'configure))))
     (native-inputs
-     (list intltool pkg-config))
+     (list
+      `(,glib "bin")
+      intltool
+      pkg-config))
     (propagated-inputs
-     (list glib
-           `(,glib "bin")))
+     (list glib))
     (synopsis "Icon taskbar for GNOME Shell")
     (description "This extension moves the dash into the gnome main
 panel so that the application launchers and system tray are combined