diff mbox series

[bug#64209,v4,08/11] gnu: Add ocaml-fiber.

Message ID c9050c4672d625856c9afeb9aeaa510bc946ceff.1711236338.git.benjamin@uvy.fr
State New
Headers show
Series Update with rebase on master | expand

Commit Message

Benjamin March 23, 2024, 11:35 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-fiber): New variable.

Change-Id: Ibfab7cde463c806a89836bc42e3b84720fbf7206
---
 gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2975a321a3..120fe4eec8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8831,6 +8831,31 @@  (define-public ocaml-chrome-trace
     This library offers no backwards compatibility guarantees.")
     (license license:expat)))
 
+(define-public ocaml-fiber
+  (package
+    (name "ocaml-fiber")
+    (home-page "https://github.com/ocaml-dune/fiber")
+    (version "3.7.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "085v1dfxrb4wnkgysghj5q4vr4nx3nxr84rqmy874dr3pk30740n"))))
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "fiber"))
+    (propagated-inputs (list dune-stdune dune-dyn))
+    (native-inputs (list ocaml-odoc ocaml-ppx-expect))
+    (synopsis "Structured concurrency library")
+    (description
+     "This library implements structured concurrency for ocaml.
+     It offers no backwards compatibility guarantees.")
+    (license license:expat)))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")